Z-Axis gradually cutting deeper in a single pass

Ive been having lots of issues with the Z-Axis, and the occasional Y-Axis (although I think I’ve fixed that).

In the past, the spindle has (honestly) just driven itself straight down through my material all the way to the collet then tried to do its thing. That has only happened twice, a few weeks ago. Today, however, I was cutting out a trigger frame for a paintball gun (out of aluminum). Last night I cut out 5 of these no problem, today on my 3rd trigger, during the profile the Z-axis just kept getting deeper and deeper until it broke my bit. It went all the way to a depth of .13" before it snapped off (the material is .16"). It’s supposed to step down .02" @ 55ipm and using cutviewer over and over confirms that there isnt anything wrong with the gcode.

Heres a picture:

Its hard to see but it starts out very shallow and steadily gets deeper and deeper. I’ve adjusted the pots on the gShield and did a soft reset in universal gcode sender and shut the power supply down and restarted. So I tried again with a new bit and something similar happened, except half way through the part it lost it’s Z-Axis position and thought it was higher than it was (thus making the bit go deeper into the material). This didn’t break the end mill at first but when you hit “Cancel Job” on universal g code sender it usually takes a few seconds for the last few lines it sent to execute, during that gap is when the 2nd end mill broke.

My machine is the 500mm x 500mm version with the ACME threaded rod, NEMA 23s, and Dewalt DW660 spindle.

Whats going on? This machine is starting to become too much of a hassle, I’ve had numerous problems with it. (power supply and gshield both fried within 2 weeks of putting it together, now this).

Did you check for tool pull out in the collet. Do you have a DRO where you can see the Z depth. Did that change with the cut.

Dave

The only DRO I have is what universal gcode sender shows, and honestly its too small and out of the way to keep an eye on. After I got it to stop though, I did move the spindle’s Z-axis back to 0 to see if it was at the top of the stock like when I started, and it wasnt.

What was left of the tool was securely in the collet post-break.

Are there rapid retracts between cuts. This could be where you are loosing steps so Z thinks it is still at the original Z zero when it is not. Because we are using steppers with open loop the software has no way of knowing that it has lost steps.

Dave

There are, but the above picture is the initial cut on the part. No retracts happened during that run. The gradually getting lower happened during the length of that cut in the picture. You can see it got from very shallow to deeper and deeper.

Can you turn your spindle on from the toggle switch manually without sending any job, and see if your any steppers getting any pulses and moves erratically.

So i did 3 dry runs, no bit with the dw660 off. I measured the starting and ending Z position using a wooden block. UGS reads out the same 0.001 as the Z-Axis before and after. I don’t think it has anything to do with the spindle itself. I read on other boards that sometimes if the power supply spindle switch is set to logic it can mess things up. Since I’m using the dw660 I’ve had it set to off this entire time.

I’m thinking this is a sporadic thing now. Maybe a glitch somewhere. What kind of maintenance can I do to ensure all the electronics are operating properly. The shapeoko wiki linked me here http://www.shapeoko.com/forum/viewtopic.php?f=5&t=2501&start=20#p19137 for tuning. Since I have NEMA 23s with a 2.8A current/phase, should I measure 2.24v (2.8A = 2.24v / .8) on the VREF? Do I need to put the axis under load in order to get a proper reading with my voltmeter? I want to tune the system to have enough power reliably since I am cutting a rather tough material for the X-Carve (only aluminum so far, haven’t tested brass or copper yet).

I’m just trying to tune the system everywhere I can. Everything is squared away and belts are tight with good teeth mesh. The only other place I can see to optimize is the potentiometers. Also, are there any technical drawings out there for guard rails? Sometimes metal shavings build up on the gantry and the v-wheels run over them. I’m thinking its possible some chips could get into a pully somewhere and jam it up for a second.

My god I have the same problem and it’s making me insane. I’m considering selling my x-carve it’s annoyed me so much. It would honestly be easier to cut it by hand. I’ve been milling aluminum for the last couple months doing facing passes, and I had amazing luck, it worked perfectly, but after hours of surface milling, the z-axis slips and dives into the material, clogging my bit. I have tried EVERYTHING.

I’ve adjusted stepper wiring, the g-sheild, made sure the delrin nut wasn’t stripping, new z-belts and pulleys, keying the pulleys, and everything else under the sun. GAHHH!!!

I have had a bad gshield which caused a dive in the z axis. A new gshield corrected it for me. But I eventually used an upgraded driver to replace my gshield.

The gshield serves it’s purpose but it definitely has its limitations and is not the most robust piece of electronics.

Emily, this is an old post. Are you still using a gshield or are you on an x controller?

G-Shield. Alas, I just don’t have money or sanity to invest in this machine anymore. It doesn’t dip over time like it used too, a problem i had before is that the z-axis would vary the DOF over time, resulting in weird stepping and wavy depth. A new firmware update fixed that.

In this post Surface Milling Aluminum! I detail my success with having my machine eat through aluminum no problem. And that was the case for a good while until recently, where i attempt to cut at any depth and it gets sucked into the material until it stalls.