Z-Axis - Home Position lost after routing

after long time, not working with the x-carve, the good news, I fixed the last problem with my z-axis steps by changing the settings fü $102 in machine settings. But there is another thing. I tried it for a long time now, i wanted to solve it alone, but i couldnt do that. So, i need your help. When homing the machine, the machine inspector doesnt shows the right settings for z-axis. x and y are ok all the time. After trying several times somehow i get the settings for the work position to 0. Normaly after homing the machine the work position should be directly in x-0,y-0,z-0, right? Then i homing the machine and fix this setting also by using G28.1. I test it if G28 would work by moving the router a bit and retouring to zero by using G28, it works. Than start routing. After routing the router returns in the position zero position for x and y, but for z-axis it returns to safety height minus routing depth. In this case 10 mm - 2 mm = 8 mm. When i now using G28 the router goes into my wasteboard for 2 mm. What can i do? Another thing, is there a another possibility to bring the router in the zero work position by using G-Code and machine settings? I never used G-Code up to this day. Would be nice to hear from you. Greetings from Cologne, Axel

I`m using Easel 0.3.14 and GRBL Firmware 1.1g and Lubuntu

Are you using homing switches on all axis?
Z will not be 0 when machine is homed.
After homing jog to any position you choose and enter command g28.1
That is where the machine will go when g28 is entered until you change it or home changes.
You must home after power cycle so the machine has a reference.

Hi, no, i`m not using home switches.G28.1 and G28 work before i run a job, after it works also, but from the wrong reference point. And yes, i homed the machine always before i start a new job.

[…z will not be 0 when machine is homed… ] - thats right. I can see it in the machine inspector, but how can i change this? I fix my home/working position and home it. Then normaly it should be x=0,y=0,z=0, but it isn`t.

Thanks for your help.

G28 and G30 is a stored offset value from machine home position (homing switches)
Without homing switches the machine position is not known to the controller.

So to have a consistent G28/G30 position its a requirement to have homing switches installed.

Typical work flow:

  • Power machine up
  • Do a homing cycle ($H)
  • Jog to your intended G28 spot and call G28.1
  • (Repeat if you want to use parking space G30, jog to position and call G30.1)
  • Setting work zero, jog to intended postion and call G10 L20 P1 X0 Y0 Z0

Now, power machine down

  • Restart it
  • Re-home ($H)
  • If you now call G28 it will move to the predefined G28 parking spot
  • If you now call G30 it will move to the predefined G30 parking spot
  • If you call G90 G0 X0 Y0 Z0 or select “Go to XYZ0” it will go to the defined work zero position (Or choose reset XYZ to zero the way your controller UI allow)

If you do not re-home, the machine is not syncronized with the work coordinate system and all defined positions will be off.

1 Like