Z axis homing switch not stopping movement

My gear: Xcarve 1000 with Xcontroller and homing switches.

Just finished setting up my Xcarve 1000 with homing switches for all 3 axis. X and Y work fine. When the switch is activated the motor cuts off. However the Z axis switch does not cut off the motor.

I ran the homing setup and at first thought I had the screw that protects the switch set to low so the carriage was hitting that before the switch was fully actuated. So I setup a meter to the switch and determined that’s not the case. The switch is closing before the carriage hits the screw but the motor isn’t disabled when the switch closes.

I have tested the switch with a meter to the screws in the terminal block in the controller and it does close. However the short doesn’t cause the motor to stop.

Any ideas how I can fix this? The switch is still intact as the screw stops the carriage from crushing it.


Go inside the X-controller and make sure that all the cables are fully seated in their sockets. The retaining clips will close prior to the cable being fully seated.

1 Like

The X and Y switches are on the same terminal and they work. The terminal block is not crooked at all.

I will try removing it and replacing it though just in case.


I had the same problem after set up and it came down to reseating all the connection inside and out, re securing the wiring to the terminal blocks and correcting the wiring on the stop switch itself.

This was all based of the recommendations from text support and it seemed to fix the issues and all was good

Hello Dave,
did you finally solve the problem?
I ran into the same issue that my z homing switch is not connecting. Checked all connection, changed cables and the switch as well. It seems to be the port on the controller.

Any advice?