Z Axis is acting strange

Problem has been going on for about a month now and I have improvised as best as I can, but I am running out of patience. After designing in V-carve with proper cut depths for profile cuts. I import into Easel and when I begin cutting it goes crazy and cuts crazy deep into the wood. Example .7’ thick piece of wood, profile cut of .7’, at 62% it has cut all the way through the wood. Also, I have been having to use a deck of cards to offset my z-axis from the material for it to cut right.

Is this a new problem?
If it was working before and you haven’t changed anything, check your Z pulleys. If you’ve changed something or the problem had always been it sounds like a step per mm calibration issue.
If you jog the Z 2", how far does it actually move?

The reasons a Z-axis go further down than intended are:
1 - It was told to go there
2 - it doesnt understand it is where it is at

Reasons for 1:
Uncalibrated / design / zeroing workflow issue / flaw in post processor etc

Reasons for 2:
Loosing steps, loose set screw, one loose motor wire

1 Like

Check your electrical connections also, I had a similar issue and one of my wires was slightly pushed out of the connector and making intermittent contact. That was fun to figure out.

I checked all electric connections on the Z-axis area today and nothing appeared loose. A for instance into my problem is today we were cutting out a project on machine the wood was .7inches thick and when I set it to .35 inch deep cut it went around it ended up cutting it out.

Did you do a continuity check or visual only?

Your problem seem to be that Z loose position, this can be from overheating the driver, forces to great etc.
Are you using the Xcontroller? If so, disable the dip switch that “reduce idle torque” and make sure GRBL $10 setting =255

I did a visual Check followed by taking a screwdriver to all just to make sure none were loose. Z Loose position?
I am not using the X controller, I am using Arduino and Gshield.

P.S. I am not the original owner of my Machine so I am in the Newbie category.

Understood, no worries :slight_smile:

Gshield - have you ever calibrated the stepper drivers?
Do you have Nema17 or Nema23 motors? (Nema17 is 1,7" wide while the 23 is 2,3" wide)

In Easel => Machine Inspector what are your GRBL-parameters? (Type $$ in the console and press Enter, all GRBL settings will be listed. Copy and paste them here)


My motors are about 2 and 1/8 wide , I have not ever calibrated the stepper drivers.

Thank you for you help.
sorry for the long delay we were away for awhile.

I am also getting in this screen “error - error:8” message

Do you design in Easel and send from Easel?

I really suspect you have issues with your Z-driver. Either set to low (causing missed steps when retracting) or set to low (cause the driver to enter overheat and enter protection state, it re-enable asap temp is below shut-off)

If the carve only follow the intended cut path, but Z weer downwards during the carve I suspect the stepper is under powered.

I design in V-carve and send through Easel.
How do you re-enable it?
The X-axis and Y-axis are great very precise. It is only the Z-axis that seems to be over shooting it target.
How do you check for these things?

In order to rule out post processor issues, make a test design in Easel and run through Easel.
Report back :slight_smile:

In light of my recent experiences, I am asking a seemingly odd question.

What are you using for a spindle? DeWalt 611, original spindle, quiet cut spindle?

I have one of the very first machines from 2015. the spindle that it came with was one of the infamous P.O.S. batch that almost no one still has running.
When they died the steppers would behave in all manner of unpredictable.
Then I went with a 300w Quiet cut spindle and all was well. Until last weekend. I first noticed the z axis kept creeping upward during a run to the point of not even being in contact with the work piece any longer.

I did a bit of investigation and found that the brushes were going away and the commutator in the motor was dirty. Cleaned it up, put it back together and tried it again.

IT WORKED GREAT! for about 15 minutes.
Then all hell broke loose. The electrical noise from the worn brushes caused all three axis’ to twitch like a drug addict in need of a fix. Kinda entertaining aside form the fact I need the machine to build a project I am working on.
New spindle showed up in 2 days, (thanks Inventables) installed last night and all is well.

After all that,
Try turning on the spindle/router with out running any code, steppers stationary and see if they twitch. if they do you may need new brushes

I use the Dewalt 611 infact i just bought an extra a few months ago.
I the router/spindle doesnt act strange.
It is when the z-axis goes down it seems to be over stepping by almost twice as much.
It would be okay but when you are going though wood like crazy or you try to cut something out and end up going into the waste board . its not fun.

I tried the test design with the little charachter.
I set the cut depth to 1/8 inch depth. it ended up cutting to about 1/4 inch depth

Sounds like your step/mm is off by a factor of two.

how do you change it to single factor?

Change this value to 160 and try again.
In Easel, Machine Inspector, Console type in $102=160, press Enter and reset the controller.
Try carve again.

If problem is solved you may want to fine tune this parameter later.

After adjusting to 160 it came very close to the 1/8 depth that was set.
What is the best way to better tune this value.

Thank you so much

1 Like