Z-axis issue: Carvey ignoring material thickness settings in Easel

Hello everyone,

I hope there is still some activity in this forum, as I’ve encountered an issue that’s proven quite challenging to resolve.

The primary problem I’m facing is that my Carvey has suddenly started consistently initiating the cutting process at a fixed depth of around 8mm (approximately), regardless of the material thickness settings in Easel. This issue appeared quite unexpectedly, and the only notable detail is that it occurred when I was attempting a 5-degree ramp setting in Easel for the first time. While it’s likely unrelated, I thought it was worth mentioning.

To clarify further, regardless of whether I set the material thickness to 5mm or 25mm in Easel, the machine consistently lowers the spindle to a height of about 8mm and begins the job. Everything else seems to be functioning correctly; the only problem is its disregard for the thickness setting in Easel, defaulting to 8mm.

I’ve been in touch with customer support, who have been very helpful, but unfortunately, none of their suggestions have resolved the issue so far. Here are the steps I’ve taken:

  • Checked the tension of the Y-belt, which appears to be fine.
  • Removed and cleaned the smart clamp twice.
  • Reflashed the controller, also twice.

I’ve also attempted to manually jog the machine along all axes using Machine Inspector, and it appears to be functioning correctly. This includes checking the homing switches, which seem to work as expected, with all of them turning green when they are supposed to. And, I have, of course, experimented with about every cut and material setting imaginable in Easel.

The next suggested step is to remove the spindle to inspect the Z-belt. However, this currently poses a challenge as I’m dealing with a (thoroughly) stripped bolt. While I work on that, I was hoping to hear from anyone here who might have experienced and resolved similar issues themselves or has any suggestions or ideas about what might be causing it, whether related to the machine or software. I’m running low on ideas.

Lastly, I apologize if my post is unclear; English is not my native language, and the terminology related to machinery is somewhat unfamiliar to me.

The thickness of the material doesn’t determine the depth of cut. Does your gcode look ok?
My thoughts would be that there’s an issue with the way you’re establishing Z-zero (smart clamp) or there’s a problem with the Z axis. I’ve had my Z axis (along with the rest of the machine) completely disassembled for tuning. Which screw is stripped? Can you get a picture?
Is your spindle loose in the mount?

Hi Neil, thank you for your quick response.

As I attempted to explain in the above post (though I may not have been clear enough), the issue doesn’t lie in the depth of the cut; it seems to cut to the correct depth. The problem is where it initiates the cutting process from. Regardless of the material thickness setting in Easel, whether it’s 7mm or 25mm, the spindle lowers to approximately 8mm above the waste board before starting. Apart from this issue, everything else appears to be functioning properly. I apologize if my previous explanation was unclear.

I agree that the problem appears to be related to the machine’s zeroing process, but I’m struggling to pinpoint what can cause this particular issue. Regarding the G-code, I’m not experienced in evaluating it, so I can’t say for sure if it’s okay or not.

The stripped screw in question is the lower one securing the spindle in place. I’m currently awaiting confirmation from support about whether I need to remove it to access the Z-belt or if I can simply remove the four screws on the sides, as I’m not performing spindle maintenance. If you happen to know the answer to this, please share.

Once again, thanks for your input, and I’m eagerly awaiting your response.

Can you post some gcode here?

Yes, you will need to remove the spindle. There are screws behind it you’ll need to access.

Again, thank you for replying.

Understood, thank you for confirming. Since removing the stripped screw may take some time, is there a way to temporarily bypass the smart clamp to test if it’s the cause of the issues? Additionally, do you have any other troubleshooting suggestions I might have overlooked?

And here’s the G-code for the outline of a small rectangle that I’ve been testing with:

G90

G21

G28

G21 G38.2 Z-71 F80

G10 L20 P1 X17 Y-12.25 Z12.7

G54

G0 Z20

G0 X20 Y20

M3 S12000

G4 P1

G0 X172.300 Y77.501

G1 Z-0.800 F304.8

G1 X161.531 Y77.501 F1016.0

G1 X161.531 Y66.732 F1016.0

G1 X172.300 Y66.732 F1016.0

G1 X172.300 Y77.501 F1016.0

G1 Z-1.600 F304.8

G1 X161.531 Y77.501 F1016.0

G1 X161.531 Y66.732 F1016.0

G1 X172.300 Y66.732 F1016.0

G1 X172.300 Y77.501 F1016.0

G90

G21

G53 G0 Z-1

G54

G30

M5

G4 P0.1

@MiRu I sent you a private message.

For that screw you’ll need to replace it I would cut it on the side using a dremel tool then use a screw driver and light taps from a hammer and replace it you never know when your really going to need it off.