Z-Axis Moves in the wrong direction

I have just set up my X-Carve and set up the machine in Easel. I have downloaded the drivers. I have access to manually move the machine and everything works correctly except for the Z Axis. When I use either the up arrow on the software or the keyboard on the laptop, the Z axis spindle moves down, and vice-versa for the down arrow (Z Axis moves up. I have checked the wiring as per the Inventables instructions and I have the Z Axis wired from left to right white, red, green, black (as you look at the back of the X =-controller. As you can only install the plug one way, I believe that it is installed correctly, however, just to provide all the information possible, the wiring is from left to right, black, green, red, white (again looking from the back of the machine). Are there any ideas on what I have done wrong. I did spen some time looking through the community and was not able to find this topic.

1 Like

redo your setup to fix-it or you flip your wires around at the back of your controller.
with the new β€œZ” this is a common issue.

2 Likes

This :point_up: :point_up:
Redo the machine setup, there is a step where it tells you to test each axis and ask whether it’s operating correctly OR if its inverted, answering these questions accurately will allow Easel to automatically send the setting change to correct this issue via a setting that is saved onto the cnc itself, no need to mess with wires. :smiley:

The machine setup repeat worked, thank you.

1 Like