Inventables Community Forum

Z axis moving 25% of normal travel

I Crashed my z-axis when reloading my machine using easel, after the crash/reload the z-axis no longer travels the correct distance. As an example if I select move 1 inch down it will move about 1/4 inch down. It is repeatable. I removed the machine and reloaded with the same results.

The physical machine has been working fine for many carves up until this event. I do not see any physical damage and I checked all the wiring connections. I am running machine using microsoft edge. I did notice on my last carve that the 2 step carve was not working, would not give option for detail pass, so this is why I was reloading machine. Two step carve has worked in the past. The only change that I am aware of between the machine working in the past and the latest project is a software update for windows.

Any thoughts would be appreciated.

You might check your $=102 setting and see if it may have changed.

1 Like

The 25% movement is an indication that the dip switches are set wrong inside the x controller

Notice the position of the white switches on the rightmost red box… its opposite if the other 2… if this is instead set to match the other 2 your z will move as 25% the commanded amounts heres more photos regarding the xcontroller for your reference:

https://x-carve-instructions.inventables.com/upgrade/step3/1assembly/

I am not sure how to check the $-102 setting.

Go up to Machine then general settings and in the console window type in $$ and hit enter and your grbl setting should come up.

Checked the dip switches and they are set correctly.

Thanks

1 Like

If the switches are set correctly, then a full calibration may be in order

new insight, all the axis, x, y, z are not working properly. x and y move 11/16 when ask to move 1 inch, Z is still moving between 1/4 and 5/16.

The crash occurred when I tried to load machine using internet explorer. I manually rotated the z axis to free the bit then went back to using chrome. I removed the old machine a reloaded the machine setting. This time confirming travel direction for each axis which is when I notice the incorrect travel.

what upgrades did you do to your machine?

Did you select the correct machine version/options? Because the selection will change the calibration settings…

Here are the defaults for the older (pre nov 2021 upgrades) and links to the settings in case yours does have any upgrades or is the whole newer version.

Good news to report, but first thanks for everyone’s help.

I went thru the calibration process explained in SethCNC video and was able to get all 3 axis tuned in perfectly. Great video by the way!

After I completed this, I read SethCNC’s last post about checking to be sure I loaded the correct machine, low and behold I had not. Went back and reloaded correct machine and it works again. Bone head mistake on my part.

The silver lining is: 1. I am a little wiser and 2. I found some great friends for the future.

Kind regards to all
David

2 Likes

Why reload the machine after a crash?
Just re-home.

I think you’ve read that backwards, he did the setup and that’s when the crash occurred.
Why did he need to do a setup?
Well there’s many possibilities that warrant a new setup be preformed:
Windows or browser update that clears cache
Wanting to use a different pc as the sender
Or the most common over the past 5 months… installing upgrades like the new z axis

Someone even made an ironically labeled video a few months ago when thst upgrade came out, before the made it as simple as doing a new machine setup…

1 Like

You might be right. This is what read that made me think he reloaded after a crash.
“after the crash/reload the z-axis no longer travels the correct distance”