Z Axis moving up instead of down HOMES FINE

I am not sure what is going on, but my machine homes just fine. When reset my zero it moves up for Z+ and down for Z- as it should. When I turn on my machine and run the program through UGS the Z axis goes up and starts the pattern. What gives?

Post the first 20 lines or so of your gcode, this will tell if its a code issue or a hardware issue.

Sounds like maybe a relative vs absolute issue.

Do you have a G90 in your header?

**** Connected to COM3 @ 115200 baud ****

Grbl 1.1e [’$’ for help]

$$
$G
$0 = 5 (Step pulse time, microseconds)
$1 = 25 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 0 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 1 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.010 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 1 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 3 (Homing direction invert, mask)
$24 = 500.000 (Homing locate feed rate, mm/min)
$25 = 8000.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 5.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 80.000 (X-axis travel resolution, step/mm)
$101 = 80.000 (Y-axis travel resolution, step/mm)
$102 = 2267.720 (Z-axis travel resolution, step/mm)
$110 = 10000.000 (X-axis maximum rate, mm/min)
$111 = 10000.000 (Y-axis maximum rate, mm/min)
$112 = 500.000 (Z-axis maximum rate, mm/min)
$120 = 800.000 (X-axis acceleration, mm/sec^2)
$121 = 800.000 (Y-axis acceleration, mm/sec^2)
$122 = 300.000 (Z-axis acceleration, mm/sec^2)
$130 = 450.000 (X-axis maximum travel, millimeters)
$131 = 390.000 (Y-axis maximum travel, millimeters)
$132 = 85.000 (Z-axis maximum travel, millimeters)

Open the Gcode file and copy and paste the first 20 lines.

Here it is:

T1
G17
G20
G90
G0Z1.5500
G0X0.0000Y0.0000S15000M3
G0X-0.4690Y0.2314Z0.9500
G1Z0.7389F30.0
G1X-0.4579Y0.2219Z0.7393F2000.0
G1X-0.4466Y0.2123Z0.7423
G1X-0.4418Y0.2079Z0.7454
G1X-0.4410Y0.2070Z0.7464
G1X-0.4410Y0.2049Z0.7500
G1X-0.4410Y0.2070Z0.7464
G1X-0.4395Y0.2053Z0.7500
G1X-0.4408Y0.2069Z0.7467
G1X-0.4388Y0.2067Z0.7500
G1X-0.4410Y0.2070Z0.7464
G1X-0.4425Y0.2085Z0.7448
G1X-0.4488Y0.2140Z0.7414

Yes, I believe so. I just post the first 20 lines of my gcode file

He does.

Also, change $1=25 to 1=255 :slight_smile:

Are you set to zero off the wasteboard or the material in Vcarve or whatever CAD/CAM program? And if its the wasteboard, are you zeroing off the wasteboard?

I’d expect negative numbers for your Z commands but they are positive, indicating your Z zero should be the wasteboard and not the material surface.

Check your origin point in your CAD/CAM.

I am zeroing off the material in Vcarve desktop, however, I had it on machine surface instead of material surface. Oops.

Where do I change the $1=25 to $1=255? In V-carve?

In UGS you’d type that in the Console input window.

This should fix your issue once you regenerate toolpaths and save them again.

No, through Easel. Press CTRL+SHIFT+D and in the command window type $=255 and press Enter. Done :slight_smile:

I don’t have Easel

UGC then, same place where you pulled out our GRBL $ parameters :slight_smile: