Z Axis Plunging too Far at Start

So I haven’t used my X-Carve in a long time. Plugged in a new laptop using Easel to cut a new design.
Everything appears to work fine but when starting, the Z axis tries to start about 1/4" below where it
has been aligned. X-Y are fine and Z appears to be correct after the initial 1/4" drop.

What is causing it to start cutting much deeper than expected?

Check your z axis calibration. There was an update a while back that reset my Z axis and I had the same problem.

How do you check calibration and do the update?

Im having same issue. Not sure how to reset z axis. Any help would be appreciated. Thank you,

Mike

@MikeBurke How are you setting your Z zero?

Thanks Neil, im only using easel in browser. Went to machine setup from the easel navbar or menu. Did the machine steps. On the do you have a probe step, i chose yes, clicked advance, clicked default settings, clicked to run a test probe.

Exited out of wizard.

Now, i just replaced 611 router with a new one because old one started making a slight clicking noise when hand turning the collet with or without bit.

Have only ever tried setting z level using probe during carve setup. Have not tried setting z manually.

Dont know anything about the advanced stuff or device interfaces, but willing to learn.

Thanks for the reply you sent earlier. Ill reply back if the router switch was successful.

What is your GRBL $102 value ?

Thanks Haldor …

Not sure what the GRBL value is … but i went to machine setup -> advanced -> machine inspector and here’s a few of the values, with grbl on top

Thank you,

$102=320.000

ok
$132=100.000
$131=750.000
$130=750.000
$122=50.000
$121=500.000
$120=500.000
$112=500.000
$111=8000.000
$110=8000.000
$102=320.000
$101=40.000
$100=40.000

Reassembling the z axis stepper motor and tightening the belt solved the problem for me … just fyi, following up.