Z-Axis stopped working

Hello All,

I am relatively new in the CNC world. I have been using X-Carve for a few weeks, and things were going fine. Yesterday I did a carve, and noticed that the carve had some issues towards the end that ruined the cut. It seemed that the Z axis didn’t go up while the spindle was moving to a different location, and removed a lot of material on the way. When I tried again, the Z-Axis was not moving anymore. Both X and Y axis are working. When running the machine setup the homing sequence wont start.

So far I have tried the following

  • I checked the connections and everything seems to be OK (Connections from the power supply all the way to the motor are fine).
  • Checked the limit switches and they are also working fine
  • I tried adjusting the current limiting pot to see if there would be any changes, but nothing happened.
  • I Checked the V-wheels and look fine
  • When manually moving the Z-axis I can see the LED on the Arduino lighting up (faintly)

Any ideas?


Thanks for the reply. I ended up checking the electronics and it seems that the gShield V5 is shot. I connected the Z-axis stepper motor to a different axis and it was responding fine. The problem seems to be an element (the DRV8818 Stepper Drivers for the Zaxis looks burnt) on the gShield.


1 Like

Inventables will send you a new one
They helped me on that.
Also does the Z move but slow with a strange grinding noise?
If so then you need to reset up the machine in Easel.
I had a similar issue and even a new board had the same issue.
I think there is some firmware thing that gets set.