Z gets progressively lower and lower

I tried running a job where there are a lot of holes. I noticed that after a while I had to stop the machine because it was cutting way too deep. I ran the typical diagnosis of “is anything loose” and everything seemed fine.

Then I thought to grab my precision gauge I use for aligning things on the lathe and was surprised to find every time the machine moves in Z, it gradually gets lower in Z. See the video here. Notice that the bottom number stops at ~-.23mm because the gauge is no longer touching the plate. I’m instructing the machine to go +10mm and -10mm over and over. In the end there it gets so low it touches the waste board.

I already tried to tweak the $102 but ended up returning it to default because it wasn’t helping. Plus, as far as I understand, even if the $102 is off it should go down the same amount that it goes up, not behave differently depending if going up or down. Right?

Bad servo?

Can you move the Z up and down by hand at all? Basically, do you have any slop in the Z-axis?

No slop at all. I’ll also add that this isn’t a “new” problem, I haven’t used the machine that much or for that long, so I think it was an issue from the start.

Any chance that shaft coupler is loose?
What’s behind the cover between the stepper and the leadscrew?

1 Like

Behind the backside at the top of the Z axis, there’s a coupler that attaches to the stepper motor shaft and the lead screw. This has come loose on a few new machines, so I’d check that coupler.

AND I suggest performing this procedure to lock the steppers as your tests could be effected by gravity while the steppers are sitting idle…

The shaft is not loose, and my x-carve already came with the steppers locked. Plus, the Z on this machine is a lead screw so it won’t just drop down even if the machine is off.

I removed the makita motor and without it goes up and down correctly. If I put even a little pressure with my hand on it, it starts to drift down.

That’s probably true but it depends on the efficiency of the screw and the load. What’s your $1 setting?

Again, any chance you have a loose shaft coupler?

1 Like

Sorry @NeilFerreri1 I misunderstood a previous comment you made and you’re correct. I thought the shaft coupler was the ring we can see at the top of the screw, but that’s not it. The actual coupler is behind the cover that sits right below the stepper. I took the stepper out and confirmed the top coupler was indeed loose. Also confirmed it fixed the issue. Thanks, @NeilFerreri1, you rock!

2 Likes

Great! I don’t have an X-carve, so I wasn’t sure what was going on back there. It definitely sounded like the issue though.

1 Like