Z Not maintaining zero

Ok, So I upgraded the belts, rollers, stepper motors, ridgidity panels and Z axis on my xcarve 1000 a couple of months ago. I have been having an issue during 3d carves (most noticeable on those). I will do a roughing toolpath and it completes with no problem. I start the finishing toolpath zeroing off the surface of the material with the zprobe (have also tried manual zero of toolpath). I start the carve and seems ok for 30 or 40 minutes of a 4 hour carve. First there are lines in the carve Then i notice that the finishing bit (Amana 1/16 TBN) is not in contact with the material any longer. I stop the carve and command return to zero where i find the tip of the bit is now roughly 1/16 to 1/8" above the material. I have tried manualy zeroing from that point and restarting, I have also tried manually setting the bit .01 below zero and resetting to zero. Same issue. Some history, I have dismantled the collet and blew it out, I have tried bottoming the bit into the collet thinking maybe i was missing a slipping bit? I also measured with the calipers the bit length from tip to bottom of collet before trying a carve and after and they are the same before and after even though the bit does not end touching the material.There is a new waste board, I have ran a vbit across the x and y axis just touching the waste board and there is no visible difference between one end and the other. We have switched the x and z cables. All produce the same result. We as suspecting a bad z axis unit and have one coming under warranty. I was hoping to see if anyone else has had any issues such as this and what if any solution was found.

On the backside of Direct Drive Z Axis Upgrade, there is a coupler with some set Alen set screws.
just behind the logo, there should be no movement.

Sorry, I should have mentioned that i checked both the coupler with the nylon inserts in it and the other side with the coupler with the worm screw allen set screw. I did not get any play by moving them and the set screw was tight. I have been told also that the unit is a non serviceable part by inventables.

Just to be safe I checked the coupler again and did not find any movement. I was however able to get about 1/16 of a turn on one of the set screws. I also noticed that the coupler is down almost againt the lower part of the unit? I am not sure if I remember this being this way when i got it or not but it does not move when i loosen the set screws. I retightened them and i am testing to see if it will retain zero throughout a carve. I appreciate your response! maybe this was my issue after all. I will know in an hour or two.Here is another picture of how the coupler looks on this machine.
Update: Still no good. same issue. after running the toolpath again and returning to zero the z is 1/8" gap over the material.

I’ve read that some of the bits are metric and will not seat properly. Is it possible your bit is sliding in?

1 Like

I think your Z axis may be mounted too high in general, resulting in lost steps…

We have tested this and the bit can reach the spoil board.

1 Like

Thanks. I have replaced the collet and tried multiple bits to no avail. I have even measured with the calipers the distance from the tip of the bit to the collet before and after a carve and it is not moving

1 Like

I did notice that if i manually move the coupler, i can move it between 1/4 and 1/2" before there is any movement of the tip of the bit. This does not seem normal as i dont think there should be any play there. How is the worm shaft attached behind the router plate? does anyone know?

Here is a short video that shows what im trying to say:

it is attached with a delrin block… here’s the old assembly manual for the old version Z axis, I believe the delrin block part is the same in the current Z axis…

I’m experiencing a very similar issue with a recent 3D carve attempt and have also made the same adjustments and completed the same inspections. It just doesn’t make any sense and just feels like it’s more of a programming issue instead of a hardware issue. I could be very wrong as I am still new to the CNC world but I wanted to join the conversation and let you know you’re not alone.


I replaced the Z Axis unit with a replacement from inventables. Problem solved.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.