Z-probe stopped working

Yesterday my zprobe decided to quit working. I’ve checked the connectivity of every connection back to the green terminal blocks on the xcontroller. In Easel it just shows the red dot when I touch it to the bit. I’ve tried going through the setup routine too and it gets stuck on the part where I touch the probe to the bit to test it. I’ve had it and used it daily for the past year so I thought it was a loose connection; but that’s not it. Hoping someone has experienced this and knows a solution- though I didn’t find the topic when I searched.

Are you using the socket connection on the X carriage? If so, with nothing connected to it, what color does it show?

My socket is a normally closed socket, so if I’m not connected to it, in Easel, it shows green, meaning it thinks you’re touching the bit.

1 Like

Mine is normally open so when the socket is unplugged it shows Red.

Maybe your socket is broken? I thought I recalled seeing another socket break recently.

Try hooking up wire directly to the Xcontroller and seeing if that works.

Thanks, tried that too. The more I’m digging into this it looks like it’s inside the x-controller.

See if the ribbon came loose and make sure it’s fully seated.


Update: I contacted Inventables “customer success” and they suggested I “check” each ribbon cable connection inside the x-controller. I took it apart and disconnected all cables, cleaned them, and reconnected. It is now working.