Inventables Community Forum

Another homing fail thread

Hey guys. Been a while since I’ve been here. The x-carve took a back seat to some other things for a while, but I’m getting back at it now. When I stopped using it, it all still worked I ordered an x-controller last week and hooked it all up. It was largely seamless, with the exception of homing. I’ve tried reading through all the threads, but I haven’t got it sorted yet. I’m hoping you guys can help me figure out what I’m missing. Here’s the rundown so far.

I ran the wire to run the 4th motor. I have used ChiliPeppr in the past, so that’s where I picked up. I tested the movement and it moves properly in all directions via manual control. When I home ($H) it homes Z properly, then I get “ALERT: homing fail”.

I opened up the X-Controller and checked the ribbon cables. As other threads have mentioned, despite the clasps closing, 2 of the connections were not fully seated. Closed it back up and tried again. Still no dice.

Per other threads, I ran the Serial Monitor in the Arduino IDE, set $10=19, issued ? and it returned:
<Alarm,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Pin:000||>

Nothing triggered. So, I manually depressed each limit switch one at a time, issuing ? after each one and appropriately, each one showed triggered as it should. So the switches seem to be functioning properly.

As a last resort, I installed EaselLocal and ran the setup through Easel. When it got to the homing, it homed Z properly, then it sat there telling me it was homing…and never went any farther. No alerts, but no progress. Not sure if Easel should throw an alert or not.

I’m really hoping you guys have some suggestions on where to go from here.

The X-controller uses 1.0c set $10=115

Here is the desription

Do the x and y motors turn after z finishes?

1 Like

Great…thank you both for the reply. I set $10=115 and now I see that the Y-axis limit switch shows as 0, regardless of whether or not I manually trigger the switch.

OK, I found a loose connection on the Y-switch at the X-controller. Fixed that, now I get this:

Alarm,MPos:0.000,0.000,0.000,WPos:0.000,0.000,0.000,Pin:000|0|0000

Manually depressing the Z, Y, and X switches changes each of the corresponding positions to 1, as expected. Testing my probe also changes the corresponding digit to 1. Does this all seem correct so far?

And @LarryM, yes, after homing fails, I can unlock it and move in all directions.

1 Like

Yes.

Any thoughts on where to go from here?

What happens when you home the machine?

Z should move up to contact the switch, then back off and contact again, slower.

Then both X and Y should start moving toward their respective switches and do the same pull off and contact again.

Yes, Z moves up, hits the switch, backs off and then moves up again slower. That’s where it bails on me. I get the alert at that point and it returns to a locked state. X and Y never attempt to move.

Post your $$ output from grbl here.

Grbl 1.0c [’$’ for help]
$$
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:01110011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1. (rpm max)
$31=0. (rpm min)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

The following link has a .zip file with a version of grbl that is stable.

Load this version of the firmware into the X-controller.

You can use Xloader to load it in.

After you load it in we need to check the grbl parameters to see if you need to make any changes.

1 Like

Ok…loaded that hex file. Here’s the $$ output…

Grbl 1.0c [’$’ for help]
modified by Larry Mayberry
$$
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=12000. (rpm max)
$31=0. (rpm min)
$32=0 (laser mode, bool)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=740.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Change the following:
$10=115
$22=1
$30=1.
$102=188.976
$130=790

Try homing again.

Unfortunately, nothing changed. The behavior is exactly as it was before.

Maybe it’s Chillipepper, do you know how to use the Arduino IDE serial monitor?

I’ve only ever been able to get it to return the result of ? It doesnt seem to respond to anything else. So, that being said…I may not know what I’m doing with it! :slight_smile:

Let’s try something else first. Start the homing cycle and wait for the Z axis to finish.

Then manually (keep your fingers out of the machine) press the X homing switch, wait about 1/2 second manually press the X homing switch again.

Then do the same for Y.

As I attempted to do this, I paid closer attention. It’s not actually backing off Z all the way. It starts to, but not enough for it to release the trigger on the z-switch before it fails. That being said, I can’t manually press the X because it trips out too quick.

Just as a test change $27=5

Try homing.

Larry, that’s brilliant. That was the solution. Thanks so much for all your time! I really appreciate it!