Arduino ATmeg328P Replacement Card caused Air Cutting

I had to replace my Arduino card after I broke off one of the four pins in the USB Female B connector. I purchased a Elegoo Uno R3 ATmega 328P. I flashed the card using Arduino v 1.6.9 grbl. I am using a Window 10 and sending file using the Universal Gcode Sender v 1.0.9. My 500 mm machine was working fine before I had to replace the card. I had set the potentiometers before and after replacement. I have replaced both the delrin nut and ACME rod on the Z axis before this card failure.

The Problem:
I started a new project on make lettering for my neighbor who is working a flag box for his father Richard Kibbey (more about his father at I carved the USAF logo without any problems (see photo). I carved the circle without any problems. When I started on the lettering for the call sign “Jolly 05”, I had a problem. It cut only “Jol” and cut the rest of the lettering in air (see and photos).

I have some video of it cutting in air if that would help any one. Looking at the Jol lettering, the lettering is jagged in the X and Y axis. Yet, the circle cut before this is true shape in the x and y axis.

I have one of two theories. This could be a thermal issue with commands dropping out in the x, y and z. I can’t explain why after the letter “l” it started to cut in the air and none of the other letters in the wood.

The other theory is there is an issue with the grbl 1.6.9 code flashed on this Arduino clone. When I flashed the card, I did see it was at 98% usage of memory. Could I have a memory issue or bit overflow problem. There could be an issue with the grbl 1.6.9 code since it was written for ATmega8 or ATmega16. If I selected a earlier version of the grbl code and re-flashed with 1.6.7 would this decrease the file size and free up some my 32Kb memory on my ATmega 328 card?

Your help with this project would be most grateful.

Thanks James

I checked the wheels and found two upper wheels on the Z axis and one wheel on the lower X axis loose. I also found both set screws on the pulley attached to the NEMA motor loose. I tighten all the wheels and set screws.

I ran three different post processor files with the spindle off and no wood installed on the board to verify if I had any more problems I adjusted the Z axis pot down after I tighten the set screws. I had Z axis drop outs near the end of the last file (~ 40 minutes of run time). I noticed the X and Z axis motors were warm to the touch. I adjusted the Z and X pot down a notched. I let the motors cool for about an hour. I ran the same file again and only the Z axis motor was warm to the touch. I had drop outs in the Z axis and made various adjustment to the Z pot. I ran the file multiple times over the next hour and half. The Z motor was warm to the touch. I think may be the belt on the Z axis is rubbing on the pulley.


Here are some screen shots I took of the current settings. I am noticing that there is no feedback on the Work or Machine Positions. Is that a setting I need to turn back on to get the Work and Machine Position to be displayed?

If you are running UGCS 1.0.9 it does not support grbl version 1.1f.

You would need to move to the nightly build to get 1.1f support in UGCS.

Yes, I am running UGCS version 1.0.9 / Nov 11, 2015) and grbl 1.6.9 flashed on the Arduino. After your post, I found a link which describes what you are talking about the upgrade I need to do (ref Grbl version 1.1f requires updated G-code senders). Thanks LarryM

1 Like


I was able to upload and extract UGcS Version 2.0 [nightly] / July 23 2017 from url address I’ll let you know if I have any additional problems.

I was able to get some time today to make a test run using the UGCS version nightly 2.0. The total cutting time was less than 15 minutes and I did not have any drop outs in the Z axis. Here is a picture of the final cut on soft yellow pine with a 60 degree V Carve, 40 ipm, 15 ipm, 21K rpm, and depth of 0.04 inches. I think I have everything resolved. I’ll post a picture of my belt on the Z axis in another thread to see if the belt is causing drop out if I have cut that are 30 minutes or longer. Thanks for the help.

Here are some photos of the final projects. Also, I have include a link to story behind the flag box for Kibbey at url address: Thank you for your help.