Cannot connect to xcarve from Mac

I am having the same problem, almost exactly as described, and have tried all the same things. I am planning to have one of the nice people from Inventables remote log in to my machine this afternoon and see if we can’t figure something out. I will report back if anything is resolved.

That’s great @BradleyKFritz. They offered to do that for me as well, but I haven’t had time. I hope you are successful in getting to the bottom of the problem.

I’m stumped Kevin. Not that it’s any help at all, but I’m in Stroud, just over the river :smile:

Cheers

Ian

Interesting. I was wondering what link there may be between the people having this problem other than having a Mac.

So, @JohnPattillo, @BradleyKFritz, and @KevinKarney you are all using Arduinos that you supplied yourself and not the ones from Inventables?

One more question that might relate to the issue: Which version of GRBL did each of you install onto your Arduino?

I am using the one supplied with the Xcarve. I started with the GRBL version already installed, but following advice from he Help desk reflashed it again, not sure what version.

Oh well, darnit. Thought I might be on to something. I flashed mine several times with different versions trying to get it to work. I last used the inventables fork of GRBL and compiled it from the arduino IDE.

Hmmm… ok, hopefully Inventables remotely logging in will help. Let us know how it goes.

Kevin Karney et al I can understand the frustration of not being able connect your Macs to the XCarve but I’m not sure the problem necessarily lies with Easel or Inventables.
I have a Mac running Yosemite (10.10.4) and Safari (8.0.7) and can connect with the XCarve without any problem…but I don’t think that I’ll upgrade to 10.10.5 or 8.0.8 in case the problem lies with something in those updates.

FYI I am running Mac OS 10.10.5 and Safari 8.0.8 on both Macs that connect to the X-Carve and both without issue.

Another Mac user here that can’t connect through Easel. I just posted this thread outlining everything I’ve tried.

This problem dates back to at least July. There are some other tips in that thread that might help. But my connection to Easel has been randomly intermittent since day one–I cannot find a pattern to reproduce/resolve the problem at all–so I’ve given up Easel in favor of Chilipeppr.

We are looking into this issue. Looking around at the other posts (like the one you posted), that issue was resolved because the Arduino did not have Grbl installed.

I’m going to reach out individually to see if we can set up a “remote debug” session to see about the problem. I’m working with the CS team on this now.

1 Like

For anyone who is experiencing the problem where you can connect with UGS but cannot connect with Easel, please post the following:

  • Open UGS and connect with your machine, then take a screenshot of the UGS interface and post it.

This will help us get to the bottom of these issues. If you would like, send me a message directly and I can guide you through debugging. I’m trying to coordinate helping CS with these issues now. Again, there is no bug that we are aware of that would cause this. We do know that El Capitan does not work as of right now, and are working to have the issue resolved before the general release to the public.

Quick note, I had John Hays with Inventables remote access to my Mac yesterday afternoon, and after trying several things, still no connection to Easel. He suspects it might be a bug somewhere in Easel. I think he said at least one other he worked with had the same result. Anyway, sounds like we just need to give them some time to figure things out.

Hi all, I believe we have fixed this problem (deployed fix just now). The cause of it was a bit long, so I wrote another post about it: FIXED: Mac connectivity issues

Testing indicates that this fixes the issue. If you continue to have problems, let me know on that thread.

1 Like

Success!!! Did not work in Firefox, but hooked right up using Chrome. Thanks!

SUCCESS ! At last. It was a bug in Easel, that the Inventables team uncovered and quickly fixed. (It was to do with the internal naming of the Arduino board - or something like that).

My X-Carve is not buzzing away under control of Easel

Thanks to jtalbot@inventables.com and his team

2 Likes

Woohoo!! Thanks to everyone at Inventables for working this one out. What an obscure problem! No wonder it took a while.

1 Like

Well done Inventables. Again, product support at it’s finest.

1 Like

Wish I was having the same luck as y’all!

Not working for me.

Have been posting my questions/info at FIXED: Mac connectivity issues