Inventables Community Forum

Cannot get my X-Carve started!

I received an X-Carve for Christmas (500mm kit). Everything got assembled last night, so I stopped for the day. Went to set it up on the laptop, cannot get the machine to be recognized by the laptop. I looked at a dozen or so posts that shared roughly the same issue. Now I am more confused than before. To start the discussion off right, here are the details I am working with:

-Blue light and fan comes on when turned on
-Green lights appear when I manually push the axis in different directions (all wiring and axis are in correct order, i.e. X-axis movement turns on the X-axis light)
-I have the Arduino software on the computer
-I am using Windows 10
-Microsoft Chrome is the browser
-I have no clue what Chilipepper is
-No connection sound is made when the USB is plugged in
-Arduino doesn’t show up in the device manager

Like I said, i’m confused and getting frustrated. Any help would be awesome.

Check to make sure that you have the gShield plugged into the Arduino properly. If they are in the electronics case supplied by Inventables it is easier to plug it in wrong than right.

As a test, you can unplug the gShield from the Arduino and then plug in the USB cable to the Arduino and see if your computer recognizes it.

If so, very carefully line up the gShield and plug it back in with the power off. You have to remove the USB cable to remove power from the Arduino.

@NicShimala also feel free to call Inventables 312-775-7009 we are back in the office and have a help team that can work with you to figure it out.

Thank you, Larry. I will try this suggestion once I get home. I will keep this thread up to date.

Not meaning to be discouraging but…There will be many hiccups along the way. Be patient and learn from every good and bad thing you do. It will come together slowly. Enjoy the whole process instead of getting overwhelmed

Well Larry, that didn’t work. I unplugged the gShield from the Arduino and checked if that would get recognize by the laptop, it did not.

From all of the posts I rea about start up issues, I haven’t seen one mention anything about the operating system being the issue, but with all the problems I’ve had with Windows 10 so far, this wouldn’t surprise me.

Do you have another recommendation to figure out my issues?

@NicShimala
Check the serial port properties for the COM port that the Arduino is connected to. It needs to have the baud rate set at 115200. To continue the debug process let’s leave the gShield off until we get the Arduino working.

Inventables is putting together a set of troubleshooting documentation. We have identified these potential causes for the machine not being able to connect. We are continually updating these documents so if someone on the forum has contributions to the problems and possible causes let us know and we can update it.

You can also contact Inventables support or call us 312-775-7009 during business hours.

Let us know if any of these solve it.

How do I go about checking the serial port? Forgive me, but this is the first time I’ve worked with an Arduino, much less had issues with a simple USB connection

Go into the Device Manager and look under the Ports heading to see the COM port that the Arduino is attached to. Open the properties for that port and see if the baud rate is 115200. If not, change it to 115200.

I dont have much to offer in terms of a solution to your issue, but a bit of a warning or friendly advice.

Do not make a habit of lighting up the LED’s when moving the steppers by hand.
When moving them manually, do so slow enough that things dont light up.

The steppers act like generators when moved manually and guess where that current goes… right into the gshield and arduino possibly frying things and then you will have a whole new learning experience ahead of you.

Hang in there, it will all start to coalesce in your mind and make sense in time.

I’m not seeing anything for a “ports”, just USB controllers, other device, adapters, software, etc.

And I checked all of the USB port options, I didn’t see anything even close to a baud rate.

This is what it looks like on Windows 7. I don’t know what it looks like on Windows 10.

You said you have the arduino software on your computer. I do not want this to sound bad but did you run the software once you downloaded the software? I sometimes have a popup telling me that the computer can not find the CNC but after running the machine setup and homing it will then see it and run fine.

Larry,
I do not have that option in the device manager for Windows 10. Is there another way to access those options?

Gary,
I did run the software, saw nothing different

Sorry, I really don’t know. I don’t have Windows 10. Maybe someone else here can address the Windows 10 issues.

Maybe you can find something in the Control Panel that will let you set the COM port characteristics.

Sorry for the delayed response, “real life” getting in the way of my play time. I took off the gshield from the Arduino, and re-flashed the Arduino. That now shows up in a new “ports” section on my device manager. With that on, I connected the gshiled and the “ports” display went away. Where does this leave me with the machine?

If you’re able to, I would call Inventables at 312-775-7009. They can help you troubleshoot over the phone and get you pointed in the right direction.

There is a device manager on win 10

Hit Win key and type “device manager” and enter.

Edit:

Nevermind… misread the post above…

This problem shows up a lot and is usually caused by mis-alignment of the pins when the gShield is plugged into the Arduino.