Can't Connect. X Controller Not Working? [Solved]

I’m having some major issues in trying to connect to the X controller to my windows 10 laptop. I’ve had a look through the forum but most of them are for the older X carve where as mine is the new one.
There’s nothing wrong with the USB ports as they work on other devices, I’ve looked in device manager (revealing hidden files) but windows 10 doesn’t have the option to look at COM ports
I’ve downloaded a simple program called COM Port Arbiter Setter to see if they’re “full” but there was only \Device\Winachsf0 in COM3, the rest were empty.
I’ve downloaded Arduino (with USB driver) but I havent really got a clue what to do with it and it because Windows 10 doesnt show the COM port list I can’t go any further with it.
I’ve downloaded the most recent Easel Driver 0.3.11 and then went back to 0.3.9 to see if it would make a difference, it didn’t.

I’m stuck, I’ve reached my limit. Any help???

I had the same problem. Don’t remember exactly what I did except I called customer service and they walked me through it. They are extremely helpful

1 Like

I feel a bit of relief that it has happened before and it’s not a fault with the machine or a building error on my part.
I’m in the UK, so I’m hoping some kind soul will be able to answer it on here.

You could try reloading the FTDI device driver.

Personal opinion = dump windows 10

Quick note on how the COM port works…

The X-Controller contains a USB-to-COM (essentially RS-232/serial) adapter, so your computer will only see the COM port if the USB is successfully connecting.


On that note, make sure all of the connections that you need to make inside the X-Controller are correct, and are fully seated. I think it’s somewhat common to get the ribbon cable flipped around on accident. If the controller board isn’t being powered, your computer won’t see anything to connect to.

I’ve tried reloading the FTDI but it goes into getting the port number, which I cant get.

Everything inside the X controller seems to be right, I know the ribbon can only fit one way in, but is there a certain way round they go, like A to A and B to B? (if that makes sense).

I think I have managed to find some of the port information in Device Manager - Action - Add legacy hardware - and then Ports (COM & LPT).
This brings up a huge list of Ports, a lot are Arduino, one being Uno, but I get a Code 10 when this is added to device manager.

I don’t know if I’m close to the answer or simply making a real mess of things.

Still stuck!

I’ve tried two other different PCs (no access to a Mac) and the problem seems to be the X controller.
There isn’t even a sound when the usb goes in.
I’ve downloaded easel local to each one as well as FTDI , but nothing.
No sign of anything in Ports in Device Manager.
Everything is wired up correctly and the two green lights are on.
Any help or suggestions?

Have you already tried a different USB cable?

I’ve tried other USBs but nothing happens.
I’ve managed to get some response though, when I take the front off and use a type b mini 2.0 usb to 3.0 usb.
It says “the last usb device you connected to this computer malfunctioned and windows does not recognize it”.

It’s not a great response, but it’s the best I’ve had so far.

Good thinking there - that eliminates the connector between the control board and the USB A port as a problem source.

Might be time to contact Inventables (if you haven’t already).

1 Like

I’ve contacted them but I haven’t heard anything from them yet. It’s more than a little frustrating, the time difference doesn’t help with progress.
At the moment I have a costly mdf and metal paper weight.

USB3.0 port?

If I manage to borrow a Mac, do I still need to download fdti and easel local?
(Going to do a X controller rebuild today)

Is this right?? Looks like there’s a little bit of room left in the socket. Feels like the usb should go further in.

Comparing against this image from the instructions…

…it looks like part of your board wasn’t properly trimmed off (the section with the squares), which may be preventing the USB connector from seating properly, which may be causing your problems.

I’ll open my controller up in a little bit and see what it looks like.

Oh my word you legend! That might be it!
I’m in conversation with the UK distributors (Robosavvy) and we’ll see if that’s the problem.

I’d say that’s as good a guess as any. Here’s a picture of mine…

The “correct” thing to do at this point, assuming Inventables agrees it’s the issue, would be to wait on a replacement board. I’d be tempted to try and cut away the extra section of board near the connector, but that would come with the understanding I’d be voiding any chance of free replacement.

Robosavvy said to snap it off and Inventables would replace it.
Just given it a go and it works! There isn’t a sound or visual notification on the pc when it goes in but it’s there as COM4 in device manager and the Carve button on Easel was immediately green after I updated the driver when prompted. The X, Y and Z wiring all matches up too.
Problem solved!

What a huge relief.




Hours of trouble shooting and wondering why the set screws to hold board in place were hitting the board. 10 second fix and it’s perfect!

1 Like

Hello my friends, I’m having the same problem and need help.
When I press the ON / OF button of the X control there is no connection and the two green lights do not light up.
I have my X-carve since 2017 and bought it at UK distributors (Robosavvy).
Soon I have some projects for Christmas and I’m distressed, what should I do?
Thanks and great weekend.