Communication Error

Good day all,

Please can you assist. I recently purchased a X-carve (500mmx500mm) and assemble it as per online instructions. Everything went according to plan and I was in seventh heaven. I got to the instruction “setup your machine”, which I did and all went fantastic. All was setup and I was re-directed to Easel for the first time. I watched the tutorial and followed the instructions to the T. The machine was responding as shown on screen.

The next moment Easel restarted and I thought, "Ok, now its my turn. I did exactly what I just saw, tried to do a test cut on a piece of wood, and kept on getting a message that no machine has be defined. I went the the machine tab,got re-directed back to, filled in all the details as I did the first time, pressed confirm settings, and a screen pops up saying “Connecting to X-carve… Plug in your USB cable and turn on the machine.” The machine is plugged in and turned on but no response further than that. I sat thinking that maybe it just takes a while, but after 90 minutes of waiting, I could no longer wait. I had to switch off and go to a meeting.

The next day, I tried again and got exactly the same problem. No matter what I do, I could not get pass the screen saying that its connecting. I thought, just maybe I did something wrong. So I uninstalled all drivers (Easel and Arduino) and tried re-installing everything from scratch. But still I can just not get it to connect.

Naturally, I considered that maybe there is something from with my PC, so tried it on two different laptops and still got the same problem. I am currently running Windows 7 and did all the original installations on the Firefox browser, then thought maybe its the browser, so I also tried Internet Explorer and Chrome but no luck what so ever. The other two laptops is using Windows 7 and Windows Vista but just no luck. I have even tried using a different connection cable, but no luck what so ever.

Please can you help urgently.

Kind Regards

Read this thread: You may need Easel Local version 0.2.2