Connection to Easel - need help on hanging screen

Can anyone help with an Easel question. I searched for help but didn’t see anything on this. I am setting up my machine, and after Easel connects it displays a screen saying it is configuring for acme but it just sits there and never gets any further. I’ve checked all connections and all look good. I can control the machine with grbl controller. Any insights appreciated.

Have you previously been able to get through the setup or connect to your machine?

There have been a couple of reports of issues with the /setup walkthrough if you have multiple tabs/windows of Easel open. I would try making sure that you have only one tab of Easel open. Let me know if that helps. If that helps then we can start tracking down the bug.

I tried with only 1 tab open and still same problem. I did not have a pc that was webgl capable before so i never connected using easel. only used grbl controller which seems to still work. I wanted to take advantage of the new apps in easel especially the load of bitmaps. any other things to try or do you think mabe I may have an issue with my uno or shield?

If you can still use grbl controller, then it’s probably not your uno or your shield. Can you try a different browser? Are you on a Mac or a PC? The multiple tab issue basically boils down to having multiple applications attempting to communicate with the X-Carve at the same time, so in addition to not having multiple tabs open, is it possible you still had grbl controller still running in the background? It might be worth trying a fresh reboot, then just opening a browser and going right to Easel’s /setup.

Adding to the multiple tab part of the equation, try using Chrome with only one tab open and no other apps open, especially Universal G-Code Sender.

Thanks for the suggestions, I tried 2 laptops and a desktop PC, and 2 different browsers (chrome, firefox) same result every time. I sent the help desk an email to hopefully get resolution on this ASAP.

First thing shut down your computer. Unplug everything that is USB. Turn on the computer with the USB unplugged. Open up Easel. Plug in the Arduino. See if the button is green and you can Carve.

Couple questions:

  1. When you connect the USB cord is the Carve button in Easel green or blue can you post a screen shot?

  2. Since it connects to grbl controller but freezes on the Easel set up it’s probably not a hardware issue. Can you send a screen shot of the grbl controller after you typed $$ and post that?

  3. Can you post a screen shot of Easel where it is hanging?


I’ll try all that after dinner tonight. I think I sent a screen shot along with the request to help. I’m not sure how to post it in this message. Can you tell me how.

Hi @psharley I missed the screen shot on the first one. After looking at it I think it might be that you have the wrong COM port selected. Can you try going into the device manager and see which COM port the Arduino is connected to? Then change the COM port to that number. You can also check in GRBL Controller to see what COM port it is connecting to.

Device manager says come that is what I use for grbl controller. The screen before that screen shot says that easel is connecting and looks like it connects then I get that screen and it hangs there

Sorry comm 6

Oh OK then change the 5 to a 6 in Easel and that should fix it.

Ok I have all the screen shots and answers to your questions Is there a way to attach a file so you can see my results?

Did you try changing the COM port from 5-6? That should fix it?

With no other usb devices the arduino shows up on com 5. If you can get the file it’s pretty detailed on where the screens hang. I found it also hangs if I try to start a carve.

It’s a good sign that the button turns green. Make sure the Gshield is seated well on the arduino. It might be a loose connection causing the problem.

When you click carve does the overlay say “Measure the material”?

Yes. It makes it all the way up till it try to turn on the motor. If you check the file I sent the link to it shows all the screens.

I opened the .zip file but there is only an .rtf and a .log file. I don’t see any screen shots.

The rtf file is a rich text format file you can open it with word pad in windows. the log file is the log from the grbl controller it is also a text file you can open with word pad. I disassembled all the electronics and rewired them checked all connections and seating of boards still no change. At this point i think we need to swap out the boards to see f it it the problem.