Did I Fry Either my Gshield or Arduino? {Resolved by buying a new computer!}

Too big a jump at this point. Just trying to make sure the Arduino and grbl are working.

There could be other factors at play stoping easel local from talking to easel e.g Firewall, Easel Local Crashing etc. Using Arduino eliminates these variables.

Stay with me Larry…
Arduino and Gshield are together again. Just trying anything at this point.
When Easel is on and trying to see/configure the machine, the 3 greed lights next to the outgoing wires blink quickly every second or so. The machine makes a quick ‘bump’ noise at the motors with the blink.
More info for you all.

Entered in $$ in Arduino IDE.
Nothing happened.

Did you change the end of line to “newline”. Enter after $$ or press the send button. Baud rate at 115200

Did the serial monitor print out Grbl 1.0c [’$’ for help]

yes. and set baud rate per comments.

Is the gShield back on?

Nothing in the serial monitor. No reaction from IDE.

gshield is back on and powered.

take it off and try again

Took off gshield. Just Arduino on USB. Restarted IDE just for hell of it.
Verified port and baud. Opened Serial Monitor & verified those.
Typed in $$ at top line. Nothing. ‘$$’ disappeared. No reaction in Serial Monitor or IDE windows.

Here’s my Arduino IDE after opening serial monitor, setting the baud rate, and entering “$$”

Also, when using Xloader, did you select the Uno as the device?

When first opening serial monitor you should see just this:

Certainly not seeing anything like your list in IDE Serial Monitor.
Yes. Selected the Uno in XLoader. Using hex file marked …2015_07_17.hex.

I just loaded that HEX file and am getting a whole lot of nothing on my Arduino.

Might be the HEX file. Let me see if I can track another one down.

Do you have a solid amber LED on your board?

solid green light on Arduino board.
Will try and find another hex file as well.

Try this one just for testing - I know its history.

https://discuss.inventables.com/t/xcarve-jtech-grbl-update-bug-fix/28943

Ok. Now i can see something in the Arduino IDE!
So awesome… if that helps, that is.
Next step? Put on Gshield and power up?

1 Like

Yes, put the gShield back on and run the same test again.

The 1.0c HEX file from https://github.com/inventables/grbl/releases worked for me and loaded. I know some users have had issues with 1.0c on the Arduino/Gshield.

There was a HEX file linked at http://bit.ly/1I8Ey4S which is the 0.9j HEX file that Inventables was using (retrieved from the history of README.md in the Inventables Github). I just tested it and it worked.

Looks like the Inventables hosted HEX file isn’t working right.

Don’t forget that Easel must be closed when trying to access the serial port from other applications…