Inventables Community Forum

Download GRBL 1.1f

I use a Raspberry Pi 3 to control my X-carve and when I run a carve through Easel I get a message about “a new firmware is available click here to download” or something similar. of course when I click it say choose your firmware version and only list 1.1f I then click on download and the it says uploading then fails. what I would like to know is where can I download the official Inventables version, or ask if someone has a copy of this 1.1f from Inventables that can send it to me so that I can update.

At this time I would not recommend updating to 1.1f, unless you have a need for some of the new features. If your machine is working to your satisfaction then I would not upgrade.

As far as I know, Inventables does not have a version of 1.1f at this time.

If you want to try it I can build you a version for the X-carve, but I don’t have time to give it a good test.

1 Like

why does Easel have the message at the top to upgrade and when I try it says download version 1.1f .
If this is not Inventables sending this from their web site then there are some real serious problems with the site being hacked. Thanks for the reply but your reply has me asking some real serious questions about the security of the Easel program as I would never want to upload something to the firmware that the company did not approve.

Easel is a young and growing product. Inventables is a young and growing business. Things don’t always get coordinated.

I doubt this is a web hack.

To the best of my knowledge, 1.1f support in Easel is in a beta program at the moment.

here are some pictures to help see what I have.

this one there is a message at the top stating that there is a new firmware.

this one shows GRBL 1.1f as the new firmware to be upgraded.

I think it’s safe to just ignore the upgrade.

Thank you, but I am still asking if anyone has this file or knows where to get it. I still would like to check it out and see if it is something that I want to use. I know that if it is working that it will be fine “just let it be” etc etc, but still as I originally posted I would like to see the file and check out the changes. this might be the best thing since sliced bread and wow oh wow I would not want to miss that.

Which machine to you have? 500 750 1000

I have two 1000X1000 machines. I bought mine and was so impressed with the open source design that I bought one in the class that I teach. I have installed the complete upgrade on both systems and the dust collection unit on the one at work. On mine at home I have also installed the J-Tech 3.8 laser and plan on getting the dust collection upgrade next. I have no network at the school as it is in a state prison setting and we are not allowed to have internet where the offenders can be at. so I only use Easel at home.

PM sent

1 Like

I hear your concerns and feel the same as you. I too noticed this “upgrade” yesterday but was too busy to bother with it at the time. So glad I didn’t, maybe?

Anyway, the reason I’m writing this post is that you mentioned you worked in a prison environment. This is fascinating. I recently toured San Quentin (San Francisco) and visited their machine shop. Really impressive to say the least. There were two 5 axis machines and a slew of 3 axis machines (about a dozen) all HAAS. There were about 15 control boards mounted to the wall where they familiarize themselves with operating the machine before actually operating a cnc. Like I said, it was really impressive classroom and incredible tour. Titans of CNC did a pilot show there. Not sure if it went beyond that.

I too work in a similar industry and we recently (within last year) opened a makerspace inside a juvenile hall. Reportedly the only in California and possibly the nation. We haven’t ventured into the CNC world yet but will have a Maslow soon.

We too find ourselves at the mercy of not having an internet connection. Good luck with your endeavors!

2 Likes

Just a quick announcement that yes there is a new version of firmware available which you will see an optional prompt for in Easel. We do recommend upgrading to the latest version as it is the most reliable known release but we have left it optional for X-Carve users. If anyone is having any problems with the upgrade please contact our support team because we want to work with our development team to pinpoint any issues as quickly possible.

1 Like

I should add that you will need to grab the latest Easel Driver first before you will see the prompt.

1 Like

@plomac

Do you have a link to the Inventables build for 1.1f for those who don’t use Easel?

1 Like

Yes sir: https://github.com/inventables/grbl/tree/v1.1f

Just click on the branches tab to reveal the other branches.

1 Like

thanks…

I installed the update. Now at the end of each carve Easle will hang at 100%. I have to select the browser refresh to get it to complete the carve. Maybe it’s my PC and maybe not. It hadn’t happened until after the update.

thanks for letting me know. I will watch for this behaviour when I get to upgrade.

thanks for the link, I will install this on the Raspberry Pi 3 and check it out to see what happens.

Hi,

I hope one of you can help me out with my problem.

Unfortunately I was so ignorant and downloaded the, what supposed to be, new grbl 1.1f firmware. However after the upload i get the NaN message in chilipeppr, aka i don’t get a return location but i can move my router. So I try to download grade to the latest version that was working correctly for me. But now the funky stuff begins.

I downloaded the 1.0c and grbl-x-carve for in the Arduino IDE, but I cant compile it for Arduino uno (just like the “tutorial” says online how to do it). Further more i dont get the correct COM port name. THe only thing I see is COM4, and not the correctly Arduino version. Even when i press on get board info it doesn’t know it.

SO my question is, does someone encountered the problem before and what is the cure for it?

I would be very happily for a easy solution.

Kind regards,

Remco