Inventables Community Forum

Download GRBL 1.1f

Thank you, but I am still asking if anyone has this file or knows where to get it. I still would like to check it out and see if it is something that I want to use. I know that if it is working that it will be fine “just let it be” etc etc, but still as I originally posted I would like to see the file and check out the changes. this might be the best thing since sliced bread and wow oh wow I would not want to miss that.

Which machine to you have? 500 750 1000

I have two 1000X1000 machines. I bought mine and was so impressed with the open source design that I bought one in the class that I teach. I have installed the complete upgrade on both systems and the dust collection unit on the one at work. On mine at home I have also installed the J-Tech 3.8 laser and plan on getting the dust collection upgrade next. I have no network at the school as it is in a state prison setting and we are not allowed to have internet where the offenders can be at. so I only use Easel at home.

PM sent

1 Like

I hear your concerns and feel the same as you. I too noticed this “upgrade” yesterday but was too busy to bother with it at the time. So glad I didn’t, maybe?

Anyway, the reason I’m writing this post is that you mentioned you worked in a prison environment. This is fascinating. I recently toured San Quentin (San Francisco) and visited their machine shop. Really impressive to say the least. There were two 5 axis machines and a slew of 3 axis machines (about a dozen) all HAAS. There were about 15 control boards mounted to the wall where they familiarize themselves with operating the machine before actually operating a cnc. Like I said, it was really impressive classroom and incredible tour. Titans of CNC did a pilot show there. Not sure if it went beyond that.

I too work in a similar industry and we recently (within last year) opened a makerspace inside a juvenile hall. Reportedly the only in California and possibly the nation. We haven’t ventured into the CNC world yet but will have a Maslow soon.

We too find ourselves at the mercy of not having an internet connection. Good luck with your endeavors!

2 Likes

Just a quick announcement that yes there is a new version of firmware available which you will see an optional prompt for in Easel. We do recommend upgrading to the latest version as it is the most reliable known release but we have left it optional for X-Carve users. If anyone is having any problems with the upgrade please contact our support team because we want to work with our development team to pinpoint any issues as quickly possible.

1 Like

I should add that you will need to grab the latest Easel Driver first before you will see the prompt.

1 Like

@plomac

Do you have a link to the Inventables build for 1.1f for those who don’t use Easel?

1 Like

Yes sir: https://github.com/inventables/grbl/tree/v1.1f

Just click on the branches tab to reveal the other branches.

1 Like

thanks…

I installed the update. Now at the end of each carve Easle will hang at 100%. I have to select the browser refresh to get it to complete the carve. Maybe it’s my PC and maybe not. It hadn’t happened until after the update.

thanks for letting me know. I will watch for this behaviour when I get to upgrade.

thanks for the link, I will install this on the Raspberry Pi 3 and check it out to see what happens.

Hi,

I hope one of you can help me out with my problem.

Unfortunately I was so ignorant and downloaded the, what supposed to be, new grbl 1.1f firmware. However after the upload i get the NaN message in chilipeppr, aka i don’t get a return location but i can move my router. So I try to download grade to the latest version that was working correctly for me. But now the funky stuff begins.

I downloaded the 1.0c and grbl-x-carve for in the Arduino IDE, but I cant compile it for Arduino uno (just like the “tutorial” says online how to do it). Further more i dont get the correct COM port name. THe only thing I see is COM4, and not the correctly Arduino version. Even when i press on get board info it doesn’t know it.

SO my question is, does someone encountered the problem before and what is the cure for it?

I would be very happily for a easy solution.

Kind regards,

Remco

The user interface to grbl (that all G-code senders use - Chillipepper, Easel, PicSender, UGCS, etc.) changed significantly with grbl version 1.1f. You need to make sure that you have upgraded your G-code sender to a version that supports the new 1.1f interface.

That could be true. However it will not fix my problem at the moment. I can’t change the interface. Thus the only option/solution is to downgrade to the version that worked correctly for me. But that is still not working.

Moved to new topic.

I’ve thought about this over the past few months and did some preliminary work to investigate a possible new version of the spindle/laser code that I produced for 1.0c using the grbl 1.1f release.

I’ve decided not to pursue this project.

1 Like

Hi, I just tried to upgrade to the newest version of GRBL 1.1f from my current version 1.0c through Easel machine setup and I keep getting “Update failed” after several attempts… (my current Easel driver version is 0.3.10). Any suggestions on how to proceed? Thanks

Hi Blake,

I have fwd. your request into support. You should get a response later today.

Best,

Phil

1 Like