DW611 with SSR control stuttering on startup

Hey all, first post here - so hello!

I built my XCarve last week and so far it’s worked well. I’ve incorporated the automatic spindle control mod for the DW611 using a solid state relay which was recommended here. It sorta works, but not really. When I start the spindle (either via Easel or via GCode) the LEDs come on and then the motor pulses slowly at first, speeds up, and finally starts. It seems to me that maybe there’s some sort of voltage ripple from the power supply. I’ve measured the voltage from the PS at both the power out pins and the spindle pins and I get 24V. I’ve checked the wiring and all seems correct. I’ve also verified that the relay is operating as expected by hooking it up to another bench power supply - it turns on instantly as expected.

The rest of the machine is working fine. Not sure what else to look at - I will try and look at the output with a scope if I can, but at a loss for other options.

Thanks!

Thanks Phil. I’ve tried a number of spindle speeds - it works a little bit better at higher speeds as you might expect, but it still isn’t an instant on - it generally takes about 5 seconds before it stabilizes.

The thing that is pointing me to a potential problem with the power supply is that it doesn’t work even if I temporarily connect the spindle control relay directly to the power supply output - it does the same exact thing. I’m wondering if there’s a bad filter cap or regulator…

You cannot control the speed of your dewalt with an SSR. Solid state relays are designed to incorporate a zero cross detection circuit, meaning they will not turn on unless you are applying power at the moment that the ac voltage swings back near 0V. Because of thise, SSRs do not “chop” their output like a mosfet, like the one used to deliver power on the Inventables interface board. If you are using an SSR, you have no choice but to operate your machine as Full On or Off. There is a way to set up your GRBL file so that the pins are rearanged slightly and the signal for the spindle is NOT pwm, but rather simply on for all speeds. I believe I recall having to comment out some stuff in the .h file and uploading grbl again with the modified program to do it. An alternative would be to always choose the absolute maximum speed so that the PWM duty cycle is 100% or close to it, though I’d recommend going with the first option. Anyways, the Dewalt has an internal speed controller, so even if you could chop the 120VAC going to the router it wouldn’t do anything. You’d have to modify the circuitry inside the router to allow for this type of control, such as with the SuperPID controller.

I just read that it’s misbehaving with the 24V connected directly to the SSR. You can test whether it’s the power supply by connecting pretty much any power supply you have lying around to the SSR input. It consumes very little current and operates at any common DC voltage. An old phone charger, laptop power supply, anything you have lying around. If it still “stutters” I’d say you have a bad SSR. What happens when you plug the router directly into the wall?

Maybe is because you are using PWM control for the SSR instead of ON-OFF? (plus the soft-start of the dewalt is making this crappy behavior?)

I have been having minor issues with my solid state relay.
I have it powering on/off my spindle and shop vac and sometimes it will “pulse” like it is trying to latch on but can’t quite do it.
Also if I move the gantry too fast the back EMF can cause it to trigger - scary!

I just switched over to a TinyG controller this weekend and it has both PWM and spindle on off outputs. I tried driving the relay directly from the 3.3v logic output (it is rated for 3v to 24v) but it has problems triggering. Once the spindle / vac are running at full sped it will latch.

So I am thinking the relay is happier with something extra in circuit with it?
I have not had time to research it. May it needs a bit of an extra load on the circuit? Some kind of pull up resistor?
I was toying with the idea of adding a indicator LED to see what effect that would have

I upgraded to the X-Controller which has the GRBL edge firmware version 1.0C. This version of GRBL has a new feature: “New ‘$’ Grbl settings for max and min spindle rpm. Allows for tweaking the PWM output to more closely match true spindle rpm. When max rpm is set to zero or less than min rpm, the PWM pin D11 will act like a simple enable on/off output”. I set the max RPM to 0 and hooked the controller PWM output to the control input of this relay and it works perfectly to control my Dewalt DW611. In fact I have the relay plugged into my Festool vacuum and when Easel turns on the router it also turns on the vacuum. I believe this firmware would work just fine with the stock controller, but I haven’t tried it personally.

2 Likes

So I did a little more looking at this tonight.

It looks like the relay may have an issue, though it’s a little strange. It works fine if it’s triggered with anywhere from 5 to 16V, which is the range of my other bench supply. But hooking it up to 24v it seems to want to “ramp” the AC voltage up - jumps right to 80V and then slowly ramps to 120. The other troubling thing is that with no input at all, it still is allowing 9VAC to pass. I don’t like that at all. I’ll replace the relay and see how it goes.

Other weird thing I found is that the spindle output terminals aren’t actually truly at zero when the switch is off - it’s actually a sawtooth wave from -24 to +24v - I hooked it up to an oscilloscope since I thought maybe there was some noise. No noise when it’s in the on or logic position, but weird to see how it goes to zero (in sum, anyway)

I’ll let you all know how I make out - thank you for the suggestions!

Look at the schematic for the power supply interface board: DIY Interface PCB Replacement

The spindle output is connected to +24V even when the switch is in the off position, and a sawtooth is simply characteristic of a switching power supply, so i wouldn’t worry about that.

In this case it’s not that I’m plugging both the router and shop vac into one relay, it’s that I’m plugging the relay and router into the shop vac. The Festool shop vacs are designed so that you plug the tool into them and they sense when the tool is on and power the vac accordingly.

1 Like

Correct.

1 Like

place a diode across the 2 terminals that powers the ssr, not the output side…

Installed a new SSR today. Problem totally resolved. Weird, but whatever - it’s working now. Thanks for everyone’s help!

1 Like

http://www.leevalley.com/en/wood/page.aspx?p=63013&cat=1,42401,72660

Kinda like this?
Thanks for the idea! I was trying to find a work around, and Festool is stupid expensive where i live.

1 Like

Yeah, that would do the same thing. In fact I just recently designed and 3D printed an adapter that will connect the 2 1/2" output of the Inventables dust collection hose to my 4" Delta dust collector hose. It’ll probably have issues with not allowing enough airflow, but I want to see if that combination has a less annoying noise than the Festool vacuum. If I decide it’s worth it I’d end up getting the kind of relay you linked to.

Festool is stupid expensive where everybody lives, but some of us love it anyway.