Inventables Community Forum

Easel Driver 0.3.12 - Linux support

Hello,

A new version 0.3.12 of the Easel Driver is now available. The next time you carve in Easel, you will be prompted to upgrade. You may also download it immediately at http://easel.inventables.com/downloads.

Release notes

  • Support for Linux (Ubuntu 18.04)
5 Likes

Thanks! This actually made my day a little better :smiley:

I have a fresh install of ubuntu 18.4 running on an old pc. The package will not install properly (or something) When i try on the command line it just gives me unsupported file. thoughts?

I had this working perfectly on my laptop before the drive just decided it didn’t want to live anymore. But now im back to square one.

Do you have a screenshot of the errors you were seeing? If possible please send me a private message with the errors you were seeing so I can help try to get Easel up and running on your machine.
If you are installing through the command line please use the following command in the folder you downloaded the file into, replacing the file name at the end, if necessary.

sudo apt install -y -f ./EaselDriver-0.3.12-x64.deb

I need a bit of driver installation coaching.

I spent the last two days installing and configuring Lubuntu on a couple of older laptops. There were lots of fits and starts while I played with various distributions before settling on Lubuntu. I am a bit fatigued and have far too much stray information buzzing in my head. That’s probably why I am stuck at a simple problem.

These laptops will be semipermanently installed in my school shop for the students to use specifically with the X-Carve machines.

I’m running Easel on Firefox with no problems. I designed a little test carve project without issue and am ready to carve. But I am having trouble installing the Easel Driver.

When I click Carve, I get the “Install the Easel Driver” pop-up with the message “No need to worry about configuration-just run the installer and you’ll be ready to carve.”

I click the option “Download for Linux”, and then I am down the rabbit hole!

I am prompted to Open with [Ark (default)] which I did.

I see the downloaded files in Ark, but I don’t know what to do next.

I see “control.tar.tz”, “data.tar.xz”, and “debian-binary” I assume I need to extract these…or maybe I need to run the binary, or ??? I’m getting prompts to name files and choose file locations and I am paralyzed by fear, uncertainty, and doubt.

I don’t understand what you mean by “…use the following command in the folder you downloaded the file…”

I’ve remembered how to get to a command line (very rusty with linux…ten years of accumulated mental corrosion), but I don’t see how to access the command line “in a folder”.

Somehow I need to tell the machine to look in the proper file, but I don’t remember (if I ever knew) how to do that. Getting old really sucks.

Edited to add:

OH, and I tried inserting the path before the file name but I keep getting “E: Unsupported file ./EaselDriver”…“given on commandline” I’m sure I’m making some sort of syntax error.

Probably not much hope of hearing back from anyone today. Oh well…

Edited again to add: I figured out how to open the terminal from within the file where the file was downloaded, but I still get the “unsupported file” error.

Nothing else to do but keep trying…fun, fun, fun…

Hey @ChristopherDahle,
Lubuntu us not officially supported distribution, and is aimed towards bit more advanced users as it does not come with some convenience software other distros do have. We recommend using standard Ubuntu 18.04 where installing Easel Driver is as simple as double clicking the downloaded file.

Now since you have already set up a couple of laptops let’s try getting this driver working on what you have.
Try running the following commands in terminal, one line at a time

cd ~/Downloads
sudo apt install -y -f ./EaselDriver-0.3.12.deb

First command changes the directory you downloaded the files to - here I assume it’s Downloads. Second command installs the Easel Driver. The EaselDriver-0.3.12.deb is simply the name of the file you downloaded.

Hope this helps!

Edited to add:

Hah! Got it. The file was not in /Downloads. Firefox had stashed it someplace else.

I would not have known what to muck around with, without your help, so thanks for that!

Stay tuned, I’m going to try a test carve in about 10 minutes!

Original Post:

I’d actually tried that already, and just tried it again being extra careful…but I keep getting the “Unsupported file error”

Anyway, It should only take me about half an hour to put Ubuntu 18.04 on one of these machines, so I am going to try that and then I will report back.

Thank you so much for your help, and I will keep this discussion up on another machine in case you have any other suggestions in the next few minutes.

1 Like

Summary of my solution:

Based on what KacperMarcisz suggested:

The correct file was not in /Downloads, so the “cd ~/” was right, but it was a different directory.

I used the PCmanFM file manager to search around to find the file, which was actually in /tmp/mozilla-user where user is the name of my machine. From there, I used a dropdown tool in the file manager to open a terminal window, but cd would have done just as well.

I had previously extracted the files using Ark. I am not sure that was necessary because the terminal window seemed to indicate the installer was taking care of it.

Bottom line is that both machines (one is Arduino/G-Shield based, the other has an X-Controller) are working just fine with Easel/Firefox under Lubuntu Linux.

Lubuntu is supposed to be a light Linux for older machines. My machines are ca. 2010 HP G-61 laptops. In the shop they will have neither bells nor whistles and will be used for the X-carves only. Schools are overflowing with obsolete computers because people in the community love to dump their e-waste on us and then claim a tax deduction, so I am going to get a few more years out of machines that would otherwise be headed for the landfill.

1 Like

I tried the linux driver under Kubuntu 18.10 and it seems to be working fine. (Only did 1 carve).
Thanks for this driver, really cool!

1 Like

Is Dedian LinuxCNC supported?
I tried 18.04 Ubuntu new install but failed to install with package installer.
I will try command line next.

Second attempt to install Linux driver!
sudo apt install -y -f ./EaselDriver-0.3.12-x64.deb
Ubuntu 18.04.1 NO WORKY! Error: “Unsupported File”
First Attempt
Reinstalled ubuntu 18.04 after downloaded your Driver from Easel and tried to install it with default package installer. Trashed that clean install BARKED! about permissions issue or something allot like a virus or it.warned about harm to PC!! to install??

We do not support distributions outside of Ubuntu 18.04. While LinuxCNC is Debian based, it does seem heavily modified so there’s no guarantee Easel Driver will work.

As far as your problems with Ubuntu 18.04 - is it possible for you to send me a screenshot of what you are experiencing? The default package manager should install the package without issues, if you are having any trouble contact me and I will try to help you get Easel up and running on your machine.

So my problem is I tried recycling an old Chromebook sideloading the version of Linux that crouton installed and now the easel driver won’t install. I know this is an issue on my end. But anything I can do to resolve this or am I in a no win scenario?

Does this mean I can use this on a raspberry pi? Or does the deb package not support ARM platforms ? Would Ubuntu on ARM be supported , for example ?

We currently support only x86/x64 Intel-compatible architecture and trying to install Easel Driver on other platforms, such as ARM, will result in an error. Since Raspberry Pi is using ARM it is not possible to install the official debian package on this platform.

That’s a shame , given how it clearly is possible for you to make a ARM compatible package , given that the community has already shown it possible with some reverse engineering.

More to the point : small ARM machines like the Pi are perfect driver machines for something like the xcarve. Perhaps you could even make your own Pi based system and offer it as a first party controller for $100 or less ?

Hi @AdamLesser,
Thank you for the suggestion. Like mentioned above, we currently do not support platforms outside of Windows, MacOS and Ubuntu Linux on x86/x64 architecture. If there’s any other platform that we will start supporting we will surely announce it on the forum.

@AdamLesser Until the official driver supports ARM, you can use my unofficial easel-driver on Raspberry Pi / ARM (I personally use it on a Pi, and I use the Easel interface on my Mac so I can connect to my CNC over the network so that I’m not tethered to USB, but you can also run everything locally on the Pi).

Was there ever an official release of the beta you sent a couple months back that fixes the chrome issue?

Just wondering as I am updating and cleaning up our machines.

I will also be testing 20.04 on one machine later today. We would really like to get everything updated while things are slow from covid-19.

Thanks!

Steve