Inventables Community Forum

Easel Local for Linux?

doubtful as its a web app. however UGS does work just fine on linux and it is local. you can build your project in easel on a windows / mac machine then export the G-Code to Universal G-code Sender on your linux computer. thats what i was doing before i stopped everything to work on my workshop.

You can also use GrblController for Linux, which I use on my Raspberry Pi, just in case you’re not too keen on running a java app.

Are you still using linux? If so, I have a few questions. Jsut bought my X-Carve 1000x1000 machine. In the past, I have used Google SketchUp to do all of my designing, then just export to STL and run that through PyCam and then off to EMC2 for cutting.

I’d like to see what your process is and what software you are using. Linux users don’t get love when it comes to CNC/Lasers and 3D printers.

I’ve never seen these Arduino controllers, either, I’ve always used Smoothieboard. So, there is probably going to be a little learning curve… if I don’t end up switching to Smoothieboard. IN the mean time, I have Raspberry Pi’s and computers running all of my toys right now, but everything is Linux.

Thanks, and look forward to seeing how you do your designs and cutting.

Will

There is no reason why easel local could not be ported to linux all the local client does is create a web server that the browser then sends to the serial bus via a little daemon. All the hard work is done in the browser/server.

Thats why the windows version includes node.js.

It’s likely to be low on Inventables list given the low price of windows computer these days.

1 Like

Agreed. Us Linux users also have to accept reality vs ability. Of course the ability exists to port to Linux. It’s the reality that it probably won’t ever happen. That’s why I’m always trying to see what other Linux users are using with their projects.

I have a somewhat related question. I am surprised that inventables releases its HW design in opensource but not the associated SW (easel). I might be wrong but I did not see easel being released as an open-source app.
For this kind of request (having a local linux-friendly version), I can fully understand that inventables does not want to put resources on it, but then the community could do it and everybody, including inventables, would benefit from it.

I just found this thread AFTER installing MINT on my laptop to run UGS (and I assumed) Easel. :frowning:

This may or may not be dependant on anything on a PI. I’ve installed on my Ubuntu system, but never dragged it over to the XCarve to test it out.

1 Like

Easel should still run just fine. You just can’t connect it to the X-Carve directly. You can use Easel to create and lay out projects, and to generate the GCode, then use UGS to actually send the GCode to the X-Carve.

That’s pretty much what I was doing with my Raspberry Pi, only I was using a different computer for creation and GCode generation and then moving to the Pi as a dummy terminal for sending.

Oh also? Killer Username!

That is a good point. In my situation, I was having problems communicating with the xcarve from UGS as well. Out of frustration, I went back to Win10.

Mike, you mentioned that you use Easel to layout your projects then generate gcode from there. I’m struggling to find any kind of option to save or export the gcode from Easel. How did you do this?

Machine -> Advanced -> Export Gcode

You can run Easel “natively” on Linux without UGS.

I’ve provided instructions here (I run the Easel driver on Raspberry Pi so that I can run Easel from a remote machine over the network):

5 Likes

@SamyKamkar I have tried this and it works great. It is much easier to use than many of the other ways and I believe that I can make my own updates without problems. I have tried this with version 3.6 local and it works like a champ then I closed the browser and run UGS to see if it released the port as it should and this also worked flawless, great job I am very appreciative of what you have provided us.

2 Likes

Great!

Thank you for the driver for linux driver for Easel SamyKamkar! I can now run Easel on my Raspberry Pi 3. I am using Bob’s CNC for the CNC and this works like a champ!

2 Likes

Awesome!

This will allow to run easel on Raspi, but will need internet connection to work? Or am I missing something?

Easel requires internet to download designs from inventables

easel-Local is the guide sender that easel uses to send Goode to USB…