Easel Not Connecting To X-Carve (Mac osx)

I’ve got my X-Carve built and ready, however Easel won’t connect to it. I’m on a Macbook pro with current OS. Easel local is installed and easel says its “up and running.” I’ve used the Arduino app to test my connection and it is connected to the computer. I verified this by looking at my system information and i see the arduino listed under usb as a communication device. I still cannot get easel to connect. It just sits there telling me to connect the usb and turn on the device. I have tried multiple USB cables with no success. Does anyone have any ideas that can get me up and cutting? Any ideas on how to troubleshoot to figure out if my components (arduino, gshield, power supply) is functioning properly? Any ideas of how to trouble shoot so that my x carve becomes more than a garage paperweight?

Are you trying to run the set up through easel? Are you using the Arduino and G-Shield that Inventables ships with the X-carve?

I know when I first attempted to get my machine to connect it’s didn’t but all I did was exit out of Easel, then connected the X-Carve, turned it on and the went back into Easel and it connected right away.

Same sequence occasionally happens with windows works if you turn off the laptop and on again.Its like if in doubt switch it off and on again.

I’ve tried the usual combinations of powering on, restarting and variations in between.

Did you run through the setup found here:

http://app.easel.com/setup

@sketch42 I have problem to pass COM step, yes I run easel setup app

Hi @ArchilTophuridze

Sorry to hear that. I’m sure someone could help, but I am responding to @KyleThomas because like me, he has a Mac and would not be dealing with COM ports… The thread was referring to Mac OS X, so on a Mac, you just plug it in and go to the site and it should just work.

On the Windows side of things I think you have to look in device manager and find the COM port that the Arduino is on and then go to the link I posted above and when you get to the COM port part, you put in which one device manager says you are using… But I could be wrong about that.

@sketch42 we have run thru the setup. After making our selections we get this screen.


It won’t ever come off this screen. We have tried many different orders of operation of powering up.

Ok, in your original post, you refer to using an Arduino app. The makes me think of a few questions that might help us help you:

  • Is this an X-Carve or and X-Carve upgrade kit for the Shapeoko 2?
  • Which Arduino App are you referring to?
  • Did you try to run a blink on the Arduino?

If I can get these answered, I might be able to help a little more.

@sketch42
Brand new x-carve
The arduino control app from arduino
i did run blink.

Did i wipe out the program that is supposed to be there? if so how do i get it back on there?

Yep, I think you wiped GRBL out… Best to follow the instructions for setup.

You’ll need to load GRBL back onto the Arduino.

Try the HEX that @NAM37 posted here:

@sketch42
As i’m new to all of this is there istructions as to how to flash the hex?

Probably best to refer to the GRBL site for that.

Once it is flashed, unplug the USB, turn off your X-Carve electronics, and restart Safari or Chrome (whatever you use) and then plug back in the USB and turn back on the X-Carve and go to http://app.easel.com/setup to get the machine set up and ready to run.

Hope this helps.

Edit: also you might want to try @paulkaplan 's hex loader found here:

https://github.com/paulkaplan/HexUploader/wiki/Using-HexUploader

@sketch42 I’ve been trying to use @paulkaplan hex loader and after i select the usb port and then the .hex file. Nothing happens. Any tips on this operation?

Do you mind posting a screenshot of what you see after selecting the hex while the Arduino USB is plugged in?

Sure.

I installed the HexUploader into my applications folder. I don’t know if its location has anything to do with it. But after i selected the .hex file to flash and select open. the window goes away and nothing happens.

And thank you for all the help!!!

1 Like

I am guessing that you’ve already installed the IDE found here?:
https://www.arduino.cc/en/Main/Software

Your applications folder is fine, or you can put it anywhere else if you don’t want it there.

I do have the Arduino Ide software installed.

OK, so in your /Applications folder you should also have the Arduino app. Is this correct? That is the one that is imortant to be in the right place.

Close all apps. Then open HexUploader.

After you have the HexUploader open and your Arduino on the button should say “Upload a Hex File”.
Once you have chosen the hex file, then some text should flash up on the left side of the HexLoader window and at the end it should say success.

After that you should close all Apps and open your browser to the Easel setup link and go from there.