Easel will not recognize driver with Carvey


I work in a student makerspace and we just received our Carvey. We were able to get it to work using a laptop with both Chrome and Firefox; however, we have had less success with the computer it will be using permanently. The permanent computer is a Windows Desktop. In Firefox, Easel connects to the Carvey, but the display isn’t rendering properly. In Chrome, Easel says nothing except that I need to install the EaselLocal driver.

###Attempted solutions

  • Restart Easel
  • Restart Computer
  • Reinstall Driver
  • Reinstall Browser
  • Try different USB port
  • Disable software
  • Disable antivirus
  • Ensure single instance of Easel is running
  • Ensure Easel is the only thing running
  • Verify that EaselLocal service is running
  • Verify that C:\EaselLocal exists

On the laptop, Easel works with both Firefox and Chrome. On both computers, the Arduino USB driver is installed and up to date. Both computers recognize the devices as COM devices.

###Software Versions
Windows 7 64-bit Enterprise Edition Version 6.1 Build 7601: SP 1
Chrome Version 50.0.2661.102 m
Firefox Version 46.0.1
EaselLocal Version 0.2.6

Windows 7 64-bit Enterprise Edition Version 6.1 Build 7601: SP 1
Chrome Version 50.0.2661.102 m
Firefox Version 46.0.1
EaselLocal Version 0.2.6

I have little idea how to proceed. Please let me know if you have any solutions or need more information.


I should add that after updating Firefox to version 46.0.1, both browsers are behaving the same.

Hi @JeffLimbocker there was an update made for Windows 7 today by @rodovich please send this to the Customer Success team so they can perform a deeper investigation on your issue.

Are you able to manually select the port? The issue we fixed today was that in Windows 7 it can’t automatically detect the port so you can manually select it.

1 Like

I saw mention of the update and have updated the driver since it was released. I have not been able to select the port. If I remember correctly, there will be a box telling me the port cannot be found, at which point I can select the port. I do not get such a box. After selecting the device, I click “carve” and am prompted to install the driver. Are there more instructions to select the port?

Also I have submitted the issue to support and linked this post.

Here are the instructions to enter it manually:

Alright. That’s the post I saw. I do not get an “Easel can’t find your machine” pop-up, only a “Heads up, you need to install the driver” pop-up.

OK you’ll need to wait to hear back from CS or @rodovich as he is more intimately familiar with the issues in Windows 7.

Sounds good. Thank you for all of your help! I’ve been very impressed with Inventables thus far!

1 Like

Hey @JeffLimbocker

If you are being prompted to download the local sender - that means that the local sender isn’t installed or did not install correctly. I recomend uninstalling any Easel local program from the computer and then reinstalling the latest version.

@SamAlaimo My apologies, I forgot to mention that. I had a previous draft of the post but it got deleted, so I seem to have missed some things. I have uninstalled and reinstalled the sender (0.2.6) four times, rebooting the computer after each install. Thinkng that it might be a version problem, I tried reverting to a previous version that worked for another user (0.2.2). This had the same problem. The latest version is currently installed. How might I verify that it is installed correctly? The directory C:\EaselLocal exists on the desktop and the contents appear to match the C:\EaselLocal on the Laptop. The service also appears to be running.

@JeffLimbocker I would shoot an email over to the support team:

Someone will be able to remote into the computer and take a look at what is going on.

Same here

You ever get this resolved?