Entering a machine’s COM port manually

Hi Windows users,

We just updated Easel to let you enter your machine’s COM port manually if Easel is unable to find it automatically. This has been a problem for some people, particularly those running Windows XP or Windows 7.

In the “Easel can’t find your machine” popup, click “Enter COM port manually” and then enter the port number from the Device Manager. (COM ports change from time to time, so you may have to do this again if you turn off or unplug your machine.)

Some people have downgraded to older versions of the Easel Driver in order to avoid the autoconnect feature, but that should no longer be necessary! We’ve fixed some bugs and made other improvements in more recent versions of the Easel Driver, so we recommend staying on the latest.

You can download the current version here: https://easel.inventables.com/downloads

4 Likes

Actually, I don’t use Easel at all. It’s a great program, but it just doesn’t fit the way I work, and we have Century-Link for our DSL provider which means we can’t ever count on being able to connect so I need to be able to work offline.

1 Like

Hi Phil , did you change over to the latest easel program ? and does it work ok ??? re the com port problem .

Might hold off a bit then , as 2.2 is working fine for me atm . Thanks for the instructions though …I’ll keep them in mind for when I do have to change .

1 Like

Absolutely sick of this machine ! havent used it in a couple of months and now when I need it it wont connect ! I had all these issues when I got the machine but by loading Easel 2.2 it fixed it and it could find the com port . My laptop is running Vista and hubbies is running Windows 7 both of which had to use 2.2 in order to work . Tried using my laptop today and its saying cant find xcarve enter manually which I have done and its just circling round and round for ages . So tried hubbies Windows 7 which had 2.2 on it and for some reason it came up you have to update Easel driver . I reluctantly have done this to the newest 2.6 and it still wont find the machine even when I enter the com port in manually . Please can you help again folks !!! I’m just about ready to chuck it through the window !

Phil , I’m stuck with this com port recognition again , dam machine . It just wont recognise it even when entering it in manually . I ve tried using 2.2 on my vista laptop which did work previously and also the newest 2.6 on hubbies windows 7 machine . Really dont know what to do next :frowning2:

I’ve finally managed to get it working again with the 2.2 on Vista. For some reason it said there was no driver for the arduino. I’ve reinstalled 2.2 and now it’s finally recognising it. Such a pain. Don’t know why it decided not to work or what happened with easel as it was loaded before. I hope when I finally do get a new laptop that I still don’t have issues.

This doesn’t work on my mac. I would love to be able to select the com / serial port but it doesn’t work. I know what port my controller is connected to. I can connect to it using Minicom, and other programs such as cnc.js, bCNC etc all can send gcode to it, but easel can’t seem to find it. It just sits there telling me to connect what is already connected.

I just got a new computer (off-lease refurb actually) with Windows 10 on it.

(Intel i7 with 12gb ram and 1tb HDD for 300 bucks is hard to pass up…)

I put the latest arduino driver on it, and then the latest (3.2) easel driver on it. And the machine would not communicate with the controller… Manually entered the port as shown above - nothing.

I went into the device manager, and changed the port communication speed to 115200 and now it comes right up. Anyone know if there’s any issue with com port speeds?

WIth this version of GRBL 115200 is the correct speed your com port should be set at. This is the same for my Raspberry pi. Below is a screenshot of a carve I am doing as I write this using cnc.js.

Yeah - I ran a small test job on it, and it’s running great.

I wonder if the lower default port speed that windows likes is a contributor to the detection issues that others have had.