Fan ramps up and down in RPMs?

Hello this is my first start up for the Xcarve and I have a problem

My Arduino enclosure fan runs high and low RPMs over and over when I turn on the power supply. I tried hooking up 2 12v fans in series and they run smoothly so I ordered a new fan and new gShield and installed them but it is like dejavu all over again!

Installed the new fan and it still oscillates rpms up and down

Could this be a power supply Issue?

Any help appreciated.


What is the current rating on the 24 volt fan?
What is the current rating on the 2 12 volt fans?

Larry, I have just purchased a multimeter how would I check that?

It should be printed on the fan label. It would either tell you the voltage and current draw, or the voltage and power rating.


It is the one Inventables includes in the package 24v 0.08A

A way to tell whether the fan itself is faulty would be to disconnect everything from your 24V power supply, connect the red wire of your fan to the + and the black wire of your fan to the - and turn the supply on. If it still goes up and down, you’ve got a bad fan

What I was hoping to find was a reason that the 2 12 volt fans work and the 1 24 volt fan doesn’t. If the 2 fans draw less current than the 1 24 volt fan then that could be the reason and would point to a bad power supply.

Are you able to run G Code? Do the stepper motors move around? If so, I seriously down a faulty power supply. 80 milliamps is nothing


I’m scratching my head over this one. This is the second fan that he has had with the same problem, however, 2 12 volt fans in series work fine for him.

I was hoping that he would try your idea for just hooking the fan to the power supply by itself to see if it is not a fan issue, but a gShield/wiring/motor issue instead.

Yes that was strange and much to my surprise when I got the 2nd fan and plugged it in and it did the exact same thing, this is why I am asking about the power supply as it is the only constant in the equation

No there is no recognition when the USB is plugged when doing the Machine Setup as it says to plug in the usb even though it is already plugged in

Did you unhook everything from the power supply except the fan? What happened?

OK I tried it and exactly the same thing, starts out high for a few seconds and then drops speed and ramps up and down, up and down …

The fan’s doing it connected directly to the power supply? Well, that is odd. What voltage do you read at your power supply with your multimeter while nothing is plugged in? Then, what is the voltage at your power supply while the 24V fan is installed? Or when the two 12V fans are installed?


That’s bad. If it really is 48 volts then you have most likely damaged the gShield.

Well thats a shame I really dont know what i could have done, the last gShield (which is the one I received to begin with) worked but the Y driver was shot so I got a new one and as son as I plugged it in it popped. So I can order another but what gives? Is this normal?

48v and yes directly connected to fan only

The fan and gShield should be run at 24 volts. The gShield cannot work with 48 volts, that’s too much.

Now I understand why the fan was doing the run up / run down scenario.