Fusion 360 question

Hello All.
I have a X-Carve and I am using it with Universal gcode sender. I have trouble getting exact dimensions when i cut with fusion 360. everything works fine with easel. I have verified that both are in the same measurement unit and tried tweaking the gcode settings but have had no luck. everything is off by a mil or two. thanks

So the cuts are perfect in Easel but not in 360? I would recommend to calibrate the steps/mm on your X & Y but it sounds like that’s not the problem…

Check your Fusion 360 cut settings.
Usually the “Leave stock amount” is checked, which will leave some material.
You can also enable a finishing pass to remove said material.

I assume that there would be a post processor necessary for using Fusion 360, are you using the correct one?

the post processor I am using is “Universal gcode sender”
I was adjusting some of the settings namely x and y step. was able to get it to cut an accurate square and circle at 1" however when I increased the size to 3" it was off by .1
Thanks for any and all help

FYI, If you are adjusting the X/Ystep settings of GRBL (aka $100,$101), then everything is not “fine in Easel " as you stated in your parent posting. The machine will move exactly the same regardless of Easel, Fusion 360, or XYZ software.
In order to get back to proper troubleshooting, what is the correct statement?
When you cut a 1” square:

  • Changing the X/Y Steps fixed the problem in Fusion 360
  • Everything is cutting fine in Easel and Fusion 360 is cutting objects too big

@ThomasKnight Universal GCode Sender is simply the program used to send the completed gcode to your machine.

I use VCarve to create my gcode (just like you’re using Fusion 360). Once I’ve made my design, I then need to save the gcode for my XCarve. When I save the code, I have to make sure I select the post processor for the XCarve - if I had a different make or model of machine, I’d select the post processor for that machine. Universal GCode Sender (UGS) is what I use to send my processed file, to my XCarve.

UGS won’t however, process this code to suit your machine, it’ll just send it “as is”.

It’s a little like printer drivers. You have a Word document and you want to print it. If you just sent your doc to the printer, the printer would make a mess of it because the file hasn’t been “processed” for that specific printer. Instead, when you print your doc, you select the printer driver you want to use and this driver then “post processes” the file, to make it compatible with your specific printer.

GCode is the same, the gcode needs to be processed so that each coordinate instruction, is accurate or appropriate for your specific machine.

Easel is pretty much designed for the XCarve and so this is probably done automatically. Fusion 360 on the other hand needs to be able to work with any cnc machine from our little hobby machines through to multi-million dollar cnc machines.

When you save your Fusion 360 file (or create the gcode), there will be an extra step somewhere, where you’ll need to tell the program what machine you are using, this way, the gcode will match your machine.

Unfortunately, I don’t use Fusion so I cannot describe the steps in detail, but if your machine works ok using easel, but does weird things with another program’s gcode, this sounds like the most likely cause.

Hello all,
Thanks to your suggestions I have taken the following steps:
1)Checked tuning on X-carve-Comes out exact every time.
2)Tried to carve different size squares and circles. From .5 up to 5. The larger the cut the greater the amount of error.
3) Tried different G-code senders and different post processors and all the cuts had the exact amount of error for the given size.
4)I have cut the same size multiple times and get the same amount of error for all cuts.
All this being said I feel like I have something not set correctly.I can fudge the size of the part and get a cut exactly what I need however this is time consuming and aggravating. Being new to the world of cad and cam any ideas would be greatly appreciated

Ok, next step is to calibrate your stepper motors, think this link covers this topic…

There is a shapeoko post-processor for F360. If I recall, it needs some tweaking to work properly with the latest grbl. I don’t recall exactly what the problem was, but there were some g-code moves near the end that cause some really odd behavior. I think I’ve uploaded my post processor here - I found it on the web and edited it a little to my needs.

ShapeOKO.cps (16.7 KB)


There sould be a generic GRBL post processor in Fusion.