G-code export stop at the first node issue

Continuing the discussion from [New Feature] New editing tools:

@koriamko can you please do some tests to find out if it is the file, the g-code, or UGS?

  1. Try carving a simple square inside easel
  2. Try Making a simple square in inkscape, importing it into Easel, then carving it
  3. Try Making a simple square in inkscape, importing it into Easel, then exporting the g-code and carving it in UGS

Can you write back what happens in each case?

1 Like

Hi, Thank you so much for your prompt reply, I appreciate your time, The squares made in easel or inkscape worked just fine but the problem arose when I used the new arc tool on the points editor to make it circular, then my machine once again would stop at the first node?. same problem if i made the arcs in inkscape. I have used easel successfully for about a year with all sorts of complex shapes, this problem seemed to arrive with the new feature.
I built my own controller so I cant run the machine directly from easel. I always export to Grbl Controller which has worked fine so far. Next time I need a controller I will be buying the X-controller :slight_smile:
Thank you

Hi @Korimako is your controller running GRBL on an arduino and your own custom shield? What version of GRBL are you using?

@paulkaplan any idea if the new feature might have broken his file?

Hi, Yes I am using an Arduino with GRBL version 0.9 with a protoneer shield, thank you so much for helping with this.

Hi, an update on the previous discussion, The short version is that I am up and running again as I am using Universal Gcode sender instead of GRBL controller. I ran some further experiments with GRBL controller which still has some problems but since the UGS has no trouble I will leave it at that,
thank you for your time :slight_smile:

1 Like

Awesome! Easel now has gcode sending and the machine inspector if that is interesting to you.

That sounds exciting thank you, I will have a play :slight_smile: