Inventables Community Forum

Generate g-code freezes

I searched found something about about easel freeze but no solution. Have a project making some coasters 24x24 inch board coasters are 4-inches each so 6x6 for a total of 36 coasters v-carving go to carve and it just just sets there at the simulating tool paths. waited 1 full hour nothing just frozen. Reload the file went to advance machine and tried the generate g-code another full hour nothing. I tried aspired 8.0 which is what I used to create the file and exported as SVG and I can generate a g-code but I can’t get the depth carve correct and easel won’t load a g-code and let you edit. Any ideas why it just freezes. I have tried it on three machines all windows 64 bit. tons of free memory. When the file load it says only 412 objects I’ve had twice a large files and never had this problem until it seems that this easel was upgraded.

Any thoughts out there.

Can you share the Easel project URL?

1 Like

How do I do that

In the file menu click share. Then post the link here.

The File finally Generated the g-code it took 2 1/2 hours have no idea why last year when I was doing these i could load it up and go to carve and be carving in 2 minutes.

Using 1/4 birch plywood 24x24 v-90 bit
that’s it.

Hi George,

I’m opening a ticket for our engineering team to look into this.

Jeff

I’ve been having a issue with easel too not generating tool path. It takes over 15 mins to simulate a simple wedding plaque . 3 layer 20"x9" first names , last name , and date and that’s it . I called thurs last week when this started and still has not been fixed . Also when it does start it doesn’t raise far enough so it cuts into my project . One more thing I noticed is that I have a uncut lip around the words . I used my digital gauge and measured my bit at .375 and that’s what I put in . But after the fact I ended up putting in under easel .350 to get red of the lip . When I put in to cut circle I put in 3.75 the actual cutout is 3.720 when it’d done Something is really goin wrong .

any update on my file. Just some more in site when I use other programs this file g-codes like in 45 sec and I would use them instead aand import to easel but I haven’t mastered all the property like deph of cut and type if bit where easel is much easyier problem is which I could live with the long g-coding it takes but if something is off then I have to change things and re g-code which again is another length of time. It seem if your in a hurry to get something done everything goes wrong go figure.

Hi George,

We are actively working on this issue. It looks like an improvement we made to quality of carve in the tool paths might have impacted tool path generation time. We are working on a solution to decrease the generation time while maintaining the quality improvement.

Thanks as I said in my last reply I’ve used a couple other software and they are do the g-code in like 45 seconds I remember last year carving these out and the easel had no problem going to carve in about a minute. Like I said I did the product g-code in the machine setup area which took a long time like 2 to 2 1/2 hours now that I have the g-code it goes right into carving. I just hope I don’t need to make any changes.

Jeff i belive i spoke with you on the phone the last few days . and i know im bugging yall but i need answeres on when the program is goin to be fixed . its been a week . ive had to give back 2 refunds since i cant do there projects and ive wasted 3 boards because the router is not lifting up high enough . so far im out $165 because of this problem . im to the point i just want a refund . i paid $200 for easel pro that i cant even use and should be a none web based software.

1 Like

Hi Melissa,

You were probably speaking with someone on our customer success team. I’m sorry you are having problems that are impacting your work and your business. That’s not the experience you should have with Easel Pro and not the experience we are working hard to build for you.

We are still actively working on the performance issue regarding the time it takes to simulate/generate tool paths. We want to be confident in the changes before releasing them. We had a fix that we tried to expedite too quickly earlier today and that we had to roll back and we do not want to do that again.

We’ll be posting here on the forum as soon as the issue is resolved.

Jeff any chance I’m going to hear from someone on a solution to my problem. I do have a project like Melissa Perkins has only I’m lucky mine isn’t due for another two weeks of course. Really would like to see a solution and if not is there anyway to get the file to go back to last years easel doesn’t do me any good with this one if it doesn’t work.

Hi @GeorgeHenry,

Could you please try again? A few days ago we fixed an issue that slowed down the toolpath generation.
In the beginning, the progress bar may seem like frozen for a little while (depending on the performance of the machine). However, it should start moving after that. When there are many shapes in the project, easel takes some time to determine whether they are overlapping.

In my machine, it stayed there about 40 seconds. And five more seconds for the completion.

We are constantly working on improving the performance of toolpath generation.

Thank you

Ruwan

Much Better I was able to generate a g-code thru the machine advance and it only took 7 minutes better than 2 1/2 hours. Thanks for working on this for me. Looks like I’ll make that deadline after all.

Mahalo

2 Likes

Hi @GeorgeHenry,

Could you please try the project on your machine again? We did few more optimizations to reduce the toolpath generation time. This time toolpath generation only took less than 6 seconds to complete on my machine.

Thank you

Ruwan.

Having the same issue. Just started about 3 days ago. here is the URL for current project.
https://easel.inventables.com/projects/iAyJDlv5zQjGY9xncsFE3w

I have a problem with my detail g code freezing up? any suggestions.