Inventables Community Forum

Grbl 1.1 g

Hello
I am still looking for a solution to my problem with error 8 in the easel. I have a 1000/1000 mm machine built on the basis of x-carve
TB6600 motor drivers and ardiuno uno board
I have updated the easel driver many times.
Grbl 1.1g tohttps: //github.com/inventables/grbl/releases hex sent by xloader
I will add that grbl 0.9 works fine, I have no errors
I load grbl 1.1g and display error 8 after a while, when the machine stops working, communication is but the machine stops, the easel displays nothing after error 8 in the inspector
I am asking for help, I don’t know what to do anymore

If this is common, try a different arduino and a high quality USB cable. Have you restarted the PC?
My guess is that you’re having a USB communication issue.

1 Like

I changed ports, I have a new usb cable, I bought a USB Hub I updated my laptop yesterday And then the same I’ll try on another laptop from my brother tomorrow

Załaduj Grbl 1.1f i sprawdz.

1 Like

The CH340g USB serial chip has been known to have issues with grbl. If you can, find an Uno with the atmega16u2, or even a different one with the CH340g. I’ve had a similar problem that were fixed with a swap of Arduino.

1 Like

That’s what I have


Will the link be good?

Thank you very much for your help, I will really be very grateful

You say GRBL 0.9 works. The functions for some of the pins on the Arduino are different in 1.ff/g.

Error 8 is a homing type error if it’s real, can also be caused by electrical noise.

If I remember correctly the pins for the Z limit switch moved from D11 to D12, when moving from GRBL 0.9 to 1.1.

See: https://github.com/gnea/grbl/wiki/Connecting-Grbl

If you have limit switches you must take this into account.

1 Like

Yes I know about it.
But I don’t have limit switches

I could see the chip in the picture you posted on the other thread.
Those blue USB cables are horrible as well, but you said you switched to a better one?

Yes, IF that is the problem.

You had this issue without anything connected to the Arduino, correct? I think switching the arduino will help.

1 Like

Yes I have a new good company cable.
Ok, I’ll order this ardiuno from the link.

Yes I did not have any problem with this ardiuno. Everything installed correctly
Version 0.9i is probably less demanding and everything worked, and 1.1g not anymore

Did you wire the controller yourself? Is it possible that one of the pins used for the limit switches is shorting to ground by mistake? Can you check the voltages on D12, D10 and D9, make sure they measure 5V?

If they are OK, maybe you have a faulty Arduino, or a bad connection.

1 Like

A grounded limit switch wouldn’t cause an error. You may be thinking of an alarm state when a machine fails to home correctly. He’s having this error pop up in the middle of a program.

1 Like

But I don’t have limits. Nor homing

I’ve disabled $ grble
I disabled in easel
Maybe it will be like you said earlier that this is bad ardiuno?

I connected the same way
Everything is fine with pins
Ardiuno, I have 3 and everyone is the same
Maybe it is like NeilFerreri1 says that I have the wrong type of ardiuno

I’m sorry for the confusion @LukaszZabuski. My previous response was to Peter.
Grbl has error messages, like what you’re seeing. It also has alarm messages, like what Peter is thinking.

Hi Neil, I didn’t realize it was happening in the middle of carving.

As he is using Arduino clones, according to the links, I guess there is a possibility that they may be causing the problem.

1 Like

try this.Make sure you are editing the config.h file inside the Arduino library folder, not your downloaded folder.

1 Like

Sorry, he is a little green, could you explain it more thoroughly with this etching
Please