Grbl default settings

Does anyone have the default settings “values” for grbl I want to start over fresh getting some bad carves thinking I must have something screwed up.

If you run through the machine setup in Easel again it should overwrite anything you may have changed. Let me know if it doesn’t work and I’ll try and get a screenshot of mine as a starting point.

Awesome thanks ! I thought about that but didn’t know for sure if it would do it

1 Like

You can try the Reset command:

$RST=$

That’ll reset it to the default values and I think Inventables has their values setup for a 1000mm Xcarve.

ok so i tried running machine setup no luck , then i tried $RST=$ now my machine is really messed up, im trying to reflash grbl onto my xcontroll with arduino ide but im under the impression it doesnt reset the $$ values how can i get these values back to day one when i first set up my x-carve?

Here are my settings from awhile ago that should be basically stock. You’ll need to modify $3 for directions and also the steps/mm. I also have homing and soft limits enabled.

$3 = 3 (dir port invert mask:00000011)
$4 = 0 (step enable invert, bool)
$5 = 0 (limit pins invert, bool)
$6 = 0 (probe pin invert, bool)
$10 = 115 (status report mask:01110011)
$11 = 0.020 (junction deviation, mm)
$12 = 0.002 (arc tolerance, mm)
$13 = 0 (report inches, bool)
$20 = 1 (soft limits, bool)
$21 = 0 (hard limits, bool)
$22 = 1 (homing cycle, bool)
$23 = 3 (homing dir invert mask:00000011)
$24 = 25.000 (homing feed, mm/min)
$25 = 750.000 (homing seek, mm/min)
$26 = 250 (homing debounce, msec)
$27 = 1.000 (homing pull-off, mm)
$30 = 1. (rpm max)
$31 = 0. (rpm min)
$100 = 40.054 (x, step/mm)
$101 = 40.054 (y, step/mm)
$102 = 188.443 (z, step/mm)
$110 = 8000.000 (x max rate, mm/min)
$111 = 8000.000 (y max rate, mm/min)
$112 = 500.000 (z max rate, mm/min)
$120 = 500.000 (x accel, mm/sec^2)
$121 = 500.000 (y accel, mm/sec^2)
$122 = 50.000 (z accel, mm/sec^2)
$130 = 790.000 (x max travel, mm)
$131 = 790.000 (y max travel, mm)
$132 = 100.000 (z max travel, mm)

$0=10
$1=255
$2=0

The $RST=$ depends on the .hex file build. Some are ok, some not.

I just realized my saved settings exclude those. Oops!

1 Like

I think I have it all figured out now… Thanks guys ill see after this carve if its working like normal, the reason i did this is because a 3d carve I was trying to do keeps coming out with bad lines as if I’m loosing steps in the Z axis , I’ve checked all my v-wheels and even the acme rod everything’s tight , except for the normal play in the z axis I don’t know why I’m getting bad carve results. if I grab the router I can flex the z axis about 1/32" up or down with not much force but it looks like its twisting the gantry , I have the new upgraded version…

here is examples
11853d1754e0dab667db683b1176d5de28309ac9_1_375x500

387d66b324ff8a1de7e79fb20e41602adf68f44c_1_375x500

Nope it’s the finish pass , my machine is broken somewhere , I’m running a .25” bit for the rough pass then finishing with .75mm :frowning:

As indicated in the thread Larry linked, the default xcarve for $100 and $101 are 40 steps/mm.

The default for $102 is 188.947 per GRBL ((Microstepping * Steps/rev) / MM_Per_rev_Z = (2 * 200) / 2.117 = 188.947)

The values I posted above were my calibrated steps/mm and not the stock.

Change the values of $110, $111, and $112. Those values dictate the rapid speeds that GRBL will use.

It’s max allowed during G1 moves. It also the G0 rapid speed.

2 Likes

@RalfFerly How far did you jog? The machine can’t reach those speeds over a short jog distance.

Jog speed in v1.1 is not the same as rapid speed.

Jog speed is independently controlled through the jog command.