Grbl Not booting error w/ UGCS 1.08

Guys…complete novice here. I downloaded UGCS 1.08 and 2.0 from GitHub but both give me an error that the Grbl hasn’t finished booting when I try to send the nc file. Using laptop w/ com6 port…works fine w/ Easel but think i need to flash the Arduino w/ latest Grbl maybe? How do I flash the Arduino w/o losing capability to go back to Easel? Anybody have a help blog on this?

Have you unlocked the grbl controller?
I had to do that before i could jog or send any code.

When the grbl controller boots it enters a safe mode, where no commands are sent to the stepper motors as a precaution, you unlock it with a command, im mostly used easel so i cant remember the command, but somone here should know it

That sounds logical…as I have no idea what the unlock command is, i’ll research it or maybe someone will comment. I did just load Chilipeppr/Grbl and was able to get it to send the simple gcode file i just made in makercam…it worked but feed rates about ripped the bit out, so I need to adjust the feedrate in the code I guess. For those using chilipeppr for first time like me…here is link to web app…http://chilipeppr.com/grbl. Once there, scroll to bottom right of screen…you will see a widget w/ “Serial Port JSON Server v1.80”. click the dropdown arrow on this widget and connect your xcarve usb & pwr on…mine is USB COM6…Click on the “Your Servers” tab and select “download Serial port JSON Server”…i selected ver. 1.8 and windowsx64 version. once the zip file completes download…open and run the “json-serial-port-server” application…leave it running I think. Then back to Chilipeppr app and again bottom right JSON server widget and hit the “reload serial Port List” icon, select the “port List” tab…click on your arduino and change baud rate to 9600…it should turn green. From there use your AXIS and GRBL widgets to rest and re-zero. After that you can run the Gcode widget on the middle left pane…

I’m not totally sure if I understand all of what you speak of here, but under the machine control tab, you chould see a ste of buttons on the left side with the labels $H, $X, $C, etc. $X will unlock the machine and let you move things around.

When I try any of those $commands it says not supported for this version

Hey Michael. What version of UGS did you download and from where?
Does Easel still work for you? IF so, I assume that means that you didn’t reflash your arduino like I did…and therefore may nee a very different fix than me but I’ll try to help as it’s a bit frustrating trying to learn all of this.
When you run your UGS what baud rate does it default to on your screen…Did you try to change the Baud Rate from 9600 to 115200 in the UGS Connection panel? Did you also confirm that your com port is also set to 115200?

Hi John. I read about the baud rate and set it to the max value and that got me going. The problem then was that it was carving on the left edge of the pc. and not the center. Can’t figure out what’s causing that. Possibly doing something in mm instead of inches??? Everything’s set to inches that I can see. Shocked there’s no basic instruction set somewhere and a list of commands would be nice. When it’s carving, what’s the best way to pause and restart? Way more questions and each one takes a day to get answers. Frustrating. Shouldn’t be this complicated. For now, the problem is why it’s carving on the left edge and would love to figure that out. Thank you for your time! Mike Rags

First off have you updated java to the latest version?

Second, regarding the off center carving, when I set my machine up to carve, I have pretty much given up on using the homing switches. I jog the spindle to where I want the zero to be, make sure I zero the z axis then close the ugs connection and turn off the power supply to the xcarve, start it all back up and confirm via ugs that work position and machine position are both at zero.

Pause and restart, UGS has pause and cancel buttons under the file tab. Stops movment of the spindle. I am not sure if it will stop the spindle since I run a 48v supply and start and stop mine manually.

And I agree, UGS could use some clear documentation as to it’s operation. it’s not real intuitive.

The “help” button will bring up a popup window with info on what some of the commands do. Check your start bar for it, it may come up underneath your current window. I run 2 screens and it shows up on my secondary.

Hey Michael. After I got the UGS running I had a similar problem where X & Y were off by a factor of 6 times and I could not Re-Zero it. So…I then went to https://github.com/grbl/grbl/wiki/Flashing-Grbl-to-an-Arduino and learned to reload COM port drivers and downloaded X-Loader from http://xloader.russemotto.com/ in order to flash a new hex file to the arduino to reset it. I then stumbled on https://github.com/grbl/grbl/wiki/Compiling-Grbl where I learned that I can’t directly flash a hex file to UNO w/o have this GRBL/GRBL-Master library added on for Arduino IDE. This takes you back to the wiki grbl home page… https://github.com/grbl/grbl … where you select the code option in the right pane and then download the zip file and unzip it. Then… follow the steps outlined here… https://github.com/grbl/grbl/wiki/Compiling-Grbl …. I then watched this DIY3DTECh video https://www.youtube.com/watch?v=lIK0azYyc_c on how to flash arduino which helped visualize the steps to take.

Next I followed this link on inventables…


about midway down, you’ll see comments between Alan David & taitleswing which really helped me.
I then reflashed the Arduino w/ the X-Loader using this recommended X-Carve hex file:
HEX file name = grbl0_9i_X_Carve_500mm_ACME.hex found here…
https://discuss-assets.s3.amazonaws.com/40663d609f18fdba06c469750eeb57c24e8ffb37a574.hex

if all that doesn’t work then follow these steps to reset your Arduino eeprom and reload the x-carve hex file.

  1. Close all programs that might be trying to connect with your Arduino (Easel, Universal G Code Sender etc.)
  2. Open the Arduino IDE
  3. Go to File - Examples - EEPROM - eeprom_clear…Click it
  4. Make sure the number that this pink arrow is pointing to is 1024 and NOT 512
    Find this line,
    for ( int i = 0 ; i < EEPROM.length() ; i++ )
    MUST BE CHANGED TO
    for ( int i = 0 ; i < 1024; i++ )
  5. Click the check mark to verify/compile and then click the arrow in the top left of the IDE…to upload the program to arduino
  6. After upload finished, close Arduino IDE, open XLoader , Make sure all your settings are correct
    Device = Uno(ATmega328)
    Baud rate 115200
  7. Load HEX file name = grbl0_9i_X_Carve_500mm_ACME.hex, be sure the baud rate is set to 115200
  8. Close X loader and open Universal G Code Sender or Easel and check operation

I have same issue. I found that if I started in easel and had the connection in green opened the carve menu and unlocked movement then closed easel and opened the ugs it worked. not sure why but did

BH