Help, Random loss of connection during carve

I was running fine all morning and then when setting up probe i lose function to jog. So i reboot the x-controller and try again and it homes fine and then again i jog and in middle if probe setup it does not want to move again??? can anyone shed some light on this? I just don’t get why i was running several programs and then this happens. I didn’t change any settings.

Check for loose wires at the motor and controller.

I’m not sure I understand your problem correctly. Does the loss of jog movement happen during the probe operation, or after you’ve homed and removed the probe? Does the “Carve” button in Easel remain green, or are you losing the connection between the controller and your computer entirely?

As cg49me said, check for loose wiring. But also look to see if you might have a short somewhere.

Ok so i think i figured it out but don’t understand why now it stops in middle of running.

I’m trying to cut something that’s 30 inches wide and my birch ply is 33 wide si entered that in size of my material in easel. the reason it stopped in middle of my set up is i think because where i wanted to jog it hit my limit switch. however i moved it and got it to start but now it started cutting and stopped when it was going in positive X and i think it because it was too far for it to travel but i checked my max work areas is set to 31.1. i don’t know why it stopped it had the clearance this time and no switches in the positive X. do i need to change grbl settings?

Post your grbl settings.
I’m a bit confused with your problem as well. Does this have anything to do with the probe anymore?

Do you have soft limits set in grbl?

No not a probe issue anymore

her is my grbl settings


Its randomly losing connection when it carves. I might have a bad usb wire. sorry my problems are over the place. I think its because im cutting something larger than I’m used to running. like I’m hitting min and max of machine.

One of the most likely errors is hitting a soft limit error. 31.1 inches = 789.94 mm

Your soft limit in x and y is 790 mm

I would turn off hard limits ($21=0) as that could also be causing errors due to electrical noise.

Here is my current problem. i just replaced usb wire in case the old one was bad and i still lose ransom connection. I will try to change the settings thanks LarryM

Not sure if you already did, but change to $20=0 and $21=0

I wouldn’t do that. Just turn hard limits off ($21=0) Leave soft limits on ($20=1).

1 Like

Was just trying to rule out the soft limit.
Now that I see the video, it doesn’t look like you’re that close to any limit. If you do as @LarryM suggested, you can rule out the false trigger.

Doesn’t that seem odd that it keeps carving after is asking “how’d it turn out”?
Also looks to have lost some steps as the path was not exactly same as previous.
At 0:11 it takes out part of the tongue.
If it looses steps it may think it is at limit.

From watching the video I don’t think it has to do with hitting a limit. It thinks the carve is over before the actual end of the carve.

The USB cable was a good thing to try.

Is this with all files or only that one?

Please submit this as an error associated with that file so someone from our tech support team can take a look on Monday. If I had to guess it sounds more like an electronics issue than an Easel issue.

Please try a seperately powered USB-hub. You may have some RF noise either within the Xcarve or somewhere else in the house that cause a USB drop-out. Getting a solid 5V feed to the USB via the hub have much better noise attenuating properties.

Another excellent source of RF-noise is brushed motors like the Dewalt and similar. Typically they are okay but if the brushes are close to being worn out they will spark more and cause a lot of RF noise.

Not sure this is the case here but it is plausible.

We have the problem as well. we think that it is caused from static from the vacuum. I have moved the plug to a receptacel on a diffrent circuit this seems to have helped.


Static from the vacuum can cause that. If it happens without the vacuum on give us a call at 312-775-7009 and one of our specialists can help further diagnose it.

1 Like

So i got a chance to dry run this program again and did not turn on spindle or vacuum and it seems to be doing fine. I’m not sure about the vacuum static. I do not have a ground in my cyclone dust collection system because i didn’t think it would matter but maybe you guys can tell from my pictures of the set up. I will try to ground it and see if that helps. Do you guys have ideas on how i can ground it best. My X-carve is in office and i have a porch on other side of wall so i decided to run hose underneath the table and through wall into porch and that is where i have my dust collection setup for less noise.

1 Like

Some good info / how-to on how to ground vacuum hose found here: