Inventables Community Forum

HTTPS for Easel (SSL)

Hi everyone,

We have been testing HTTPS support for Easel for a while now, and we’d like open up the testing to all users of the forum who are interested. If you’d like to switch to using HTTPS for Easel so that all traffic between your browser and Easel is encrypted, please visit the link below and check the box to opt into beta testing.

NOTE: You will need to re-run the machine setup process after turning on HTTPS.

If at any time you experience an issue that you think might be related to HTTPS, you can turn the feature off by unchecking the box on this same page. You can also provide feedback about your experience using this feature there:

https://easel.inventables.com/features/https-for-easel

Cheers,
Jeff

4 Likes

Can you explain more in detail what the advantage of this is in our daily use of easel

It will provide the same experience, except with enhanced security. The web is moving towards all sites using https in order to make browsing safer. You can read more about this here:

1 Like

Hey,

I switched this on last night and not sure if it is the reason, but all of my machines this morning have wrong machine settings, including my Linux boxes.

Even after running the setup again , it left the work space size at 11.4 in instead of … whatever it is suppose to be for a 1000 x 1000.

Had to turn off SSL, it doesn’t appear to be saving machine settings , ran setup and tried carve again. It didn’t recognize I was using a z-probe even though I set it up in the setup procedure.

Oops, I’m sorry I forgot to note that you will indeed need to re-run machine setup after turning on HTTPS. The reason for this is that https and http do not share the same local storage database, which is where Easel currently saves machine settings. I’ve updated the original post above to make it clear that step is required.

I am surprised you are having a problem saving settings after running machine setup with HTTPS turned on, though. We have not had any reports of that issue from other testers. Are you certain that the secure lock was showing when you ran the machine setup?

I figured that once I saw the missing settings :slightly_smiling_face:

Yes I am absolutely sure, it happened on my office computer too even after running setup the work area size did not change ((I don’t have drivers loaded on this one), on our 1000 in the shop the machine size didn’t change and it did not recognize that I had setup the z-probe, not sure what else didn’t setup, I stopped when I saw the z-probe problem. At this point I turned off SSL

Machines were busy today but I will try again tomorrow on both machines in the shop and let you know.

Steve

possibly there are some “clear on close” browser settings that might be preventing persistence?

I switched it back to SSL this morning and our 1000 x 1000 machine setup was not correct, basically the same way I left it when I turned off SSL. I cleared cache on browser and tried the setup again and everything seems to work fine.

Our little 500 x 500 worked perfectly the first time. It’s the old machine with no z-probe etc. and runs Linux

It was probably something i did wrong… anyway all looks good now.

1 Like

That’s great, I’m glad you got it working!

1 Like