Inventables Community Forum

Import Issue in Easel using GCode from Fusion 360

I’ve been playing with complex 3D curves in Fusion 360, and importing the GCode into an Easel session in its own workpiece. So I do all of my 2.5D carving as normal with Easel, then go to the new workpiece in Easel to incorporate curves.

My issue is when the GCode generated by Fusion 360 has finished carving successfully, and the cutter is at its lowest depth in the Z axis, the machine returns home without retracting, eating everything in its path.

Does anyone know what GCode I would need to append to the end of my existing GCode to force a full retract before returning home?

Assuming G21/millimeters: G53 Z-5 will bring you up to 5mm below your Z limit.

What post processor are you using? That shouldn’t happen.

Easel should add a retract and return to zero anyway, though.

I’m using an X Controller. It only happens when running GCode from Fusion 360… Things I CAD in Rhino are always perfect.

Where is zero?
Can you share your gcode or fusion file?

I just use the zero where the limit switches for the X and Y axis are, so zero is front left of the machine.

I didn’t keep the GCode from the file unfortunately- anything that didn’t work was deleted from Easel in case I accidentally ran it again. I do remember someone else was saying they had this same problem with Fusion GCode, but I can’t find it with the search function.

Basically everything is normal, except Fusion Gcode doesn’t retract before returning home at the end of the job.

What post processor in Fusion?

I’ve only heard of this when your Z-zero is set at the bottom of your workpiece because of some stuff Easel adds.

Did the carve complete? I think that could happen if it was cancelled or had an issue.

My Z zero was set with the probe, from the top of the stock. The carve completed, and I was watching it and feeling very happy, then BRRRRRRRRR!!! right through the workpiece on its jolly way home.

I think you’re right though- it is something that Easel added.

Not sure what my post processor in Fusion for exporting GCode is right now, that computer is updating its OS.

When you get the chance do post some gcode otherwise we will just be guessing :slight_smile:

I suspect there is a G28 command in there somewhere at the end.

Here is a comprehensive write-up:

Yup. Some post processors use G28 and assume you have that set with your Z up.

Easel still raises to a safe height before returning home, so my guess is the post processor.

Here it is…

Open up the Properties tab in the PP box, is “Use G28” unchecked?

1 Like

I don’t have an option for that in my properties box…

I use a PP from Strooom which let you define where you want the machine to retract to after a carve, its downloadable from here - A better Fusion360 - GRBL PostProcessor

This PP is dependant on homing switches.

1 Like

Is there a bit of code I can append to the end of my GCode to make the spindle raise to its safety height before returning home? I’m a bit lost in all of this.

Yes…

1 Like

Thank you. I’m very new to this side of things, so I’m just trying to catch up with what everything means. I’ll have to get a GCode editor and do some experiments…

Thanks for your assistance.

If you share some gcode, even a test. It’ll make it more clear what’s going on.

Strooom-post allow for that, no need to copy/paste gcode snippets :slight_smile:

1 Like

i had the same issue awhile back with running my fusion models in easel if my Z was not pointing up in my setup and from the looks of your setup that is not the case. you change the orientation in your setup by clicking on the arrows to reorient the z to point up. after i reset that i never had that issue again. also set your stock point to be in the front top left corner of the stock, this too gave me issues when my fusion models had that set to the bottom of the stock

I’m having similar issues with my g-code import from fusion. I used the post-processor plugin as suggested by Inventables. However, when I went to set up my part for cutting, I noticed that my imported g-code had moved my file OFF the wasteboard. How can I fix this?