Importing G-code file, but problems with Easel..?

You have already created your toolpaths.
Now close that tab.
snip
This will take you to the setup tab.
click on the toolpath you want to save and click the save button.
snip1
when you click the save button, you will see the post processors available to you.


Click on the appropriate x carve (inch or metric) and save to the file that you created when you first started the design.
Its in alphabetical order so the xcarve will be at the bottom of the list.
you will need to do this for every tool path.
These will be the files that you send to your controller.

This is the part you’re leaving out. How do you send those files to your controller?

I use Picsender.
click “load” and select the toolpath from your file.
then click send.
The machine will start and you will be happily watching.

This snip is not accurate because I am currently not hooked up to my machine.
But the process is.

1 Like

Thank you. Everything you said ^ about saving it using the post processor I’m familiar with. Picsender is news to me. I’ll check it out.

Check out their website.
If I’m not mistaken, you can download a demo version and play with it.
Their support is also fantastic. You will not be disappointed.
(no I don’t work for them. Just a very satisfied customer)

1 Like

:crazy_face:

Just to clarify as I know @VeteranWoodCo is newer to this. You are using Easel as a gcode sender in the same way Jan is using PicSender.
For what it’s worth, I use CNCjs (mostly), and find it to be excellent. I ran a job a couple days ago with 3 tool changes exported as one file from V-Carve.

@JanVanderlinden V-Transfer is the built in sender for vectric. Don’t bother with it.

1 Like

Neil,
You’ve shown me the error of my ways.
I once again misunderstood the original situation.

Evening update. Thank you for everyone’s input. I dabbled a little bit with Picsend, then tried CNCjs, but ultimately ended up using Easel to make the carve. However, after 5 attempts, I continued to have pathways off between bit changes. I only re-probed after the bit change, kept the existing home location, and off it would go, cutting nearly 1/16th-1/8th inch off path. My Y-Axis Carriage feels snug up and down, and doesn’t have any play in it, but seems to move way to easy if accident bumped. Tomorrow I’ll give everything a once over and try again.

Hey @MarkA.Bachman, how do I go about making one gcode file out of multiple tools paths with use the same bit? I tried selecting multiple check boxes, but only one toolpath would save.

Make sure the tool paths you want are checked then make sure you check “Output all visible tool paths to one file”.

Beautiful. Thank you

For the lost XY on bit changes there are two main things to check:
In your GRBL settings, you want to make sure that $1 = 255
and

1 Like

Thank you, forgive me because when I said I was new to this, I meant BRAND NEW to CNC. Where do I check those settings?

In Easel:
Machine–>Advanced–>Machine Inspector
In the console, when connected to the machine, type $1 = 255
That’s it.

The dip switches are inside the X-Controller.
Shown ON in the image below…you want them OFF.

Some info so that you’re not blindly changing things based on some “pretend expert”:
$1 = 255 is the setting to keep the axes motors enabled whenever powered on. Source
The fourth switch does a similar thing…it reduces the holding torque on idle (not moving) motors. Turning it off keeps them enabled when the machine is on. They’ll only move when you tell them to or if you really want to try to move them by hand.

3 Likes

Thank you @NeilFerreri1, Iv updated the GRBL settings, dip switches, and tightened up the eccentric spacers on the X+Y axis, the carriages were very easy to move by hand. Seems like shes tighter now, but moves easily when commanded to.

Update. Tightened up everything. Adjusted settings/dip switches. First cut of the day, nailed it. Thanks everyone, really appreciated the sharing of knowledge.

1 Like

It looks great.
Sorry about my confusion earlier.

1 Like

@NeilFerreri1 The photo you have attached are the dip for 4 Off when they are to the right? I see the word on and it might be confusing me

In that image the switch is on. I was saying they need to be turned off.

Thanks just wanted to be sure

1 Like