Invalid gcode help

Yesterday I did a rough and finish gcode using vcarve pro with no issues. This evening I did another rough and finish gcode for another project. The finish gcode is fine but I’m getting the following for the rough cut gcode. How can I fix? I ran the tool paths several different times and saved them and getting the same exact message.

i just tried to do a new project in vcarve pro. i saved the rough and finish gcodes in separate files like i always do. i got the same basic results. i was able to get the finish gcode but was unable to get the rough gcode.

what i failed to mention was i upgraded from 10.504 vcarve pro to 11 vcarve pro today. I still have the version 10.504 so i just made the same file and it imported both gcodes just fine. so im guessing it is a vcarve pro 11 problem. im going to try to contact them tomorrow

Grbl won’t work with all the possible Gcodes that can be used. Check to make sure that you have the correct post processor selected for the new version.

i did. its set for xcarve (inch)(*.gcode)

I had a problem after I upgraded also, I contacted Vetrics and they sent me a different Post Processor for Easel.
In VCarve go to File, Open Application Data Folder, then put the Easel PP in the PostP folder


thank you for the reply. im not very computer literate. I was able to download the easel grbl code you put here. i was also able to follow file, open applications folder, and found the postP folder. when i download the easel grbl it gives me option to open file but nothing else. how do i either open the file to put in postP folder or where do i find the file to put it im there? when i try to open file, i dont have a program to do so.

This is what I’m seeing

Can you left click on where it says Open file and drag it to the desktop?

I was able to drag it to desktop. Then I dragged it to the correct folder. Can you look at your folder and tell me if it looks the same as picture below. Once I had it in correct folder I tried again got same error in easel. Pictures below

I don’t know which order you will see these but I have responded to you twice

That’s how my folder looks. It may be something else is wrong.

Did you select the Easel Post Processor when you saved your job?

yes i sent a picture of that. on the bright side i still have version 10.504 until i can get this figured out and it still working just fine. i was just looking forward to the new tool paths for the 3d stuff.

The picture you sent has the XCarve (inch) Post Processor selected

You should select the Easel Post Processor

1 Like

that did it!!! thank you so much!!

1 Like

it wasnt in the list but i clicked on a folder tab in the main post processor screen and was able to add it from there

Awesome, You’re welcome
Good Luck

1 Like

dump easel , i did . Try using UGS