Job quits in middle of carve, asks how things look

This has happened a few times now. In the middle of a carve, the machine just rests and Easel pops up a “Hey, how does everything looks?” Regardless of whether I click “It looks great” or “No, there was problem”, the machine doesn’t return to the project home.

This has happened both with g-code from Fusion360 and (like right now) in an Easel project. Not sure if this is related to Easel Pro, but it’s only happened since the EP early release.

Rerunning the job seems to work, so doesn’t look to be a problem with the g-gode. The host compute is set to not sleep, so that shouldn’t be a problem. Besides, it was a two stage carve and the first stage ran for an hour. The stall happened ing ht second stage after 10 minutes.

These stalls have happened e.g. 2%, 20% and 60% into a carve.

This happen to anyone else?

Search usb disconnects or similar. This is a pretty common problem where communication is lost between computer and the controller (Xcontroller is more prone to it).

You ever get this fixed? Starting to ■■■■ me off nobody has a answer

I’ve never personally had a USB disconnect issue.

The remedies that usually help people that have:

  • shielded usb cable
  • powered usb hub
  • bypass the Xcontroller bulkhead
  • turn off usb power savings feature
  • put router/shop vac on separate circuit (I’ve done that since day 1)

bypass the Xcontroller bulkhead ???

Yes, there was a batch of bulkheads (front plate) where the USB connector wasn’t good, connecting the USB directly to the PCB board inside the controller is a possible fix.

You would hope, but no. It’s wholly unreliable. I’ve had it happen about half a dozen times. The fact that Easel responds asking me how things look makes me uncertain if it’s an Easel or X-Controller issue. I’ve never had it happen while using another sender, but the incidents have been too infrequent to know if that’s merely by chance or cause.

The result is, I don’t throw another $80 piece of walnut on the X-Carve and watch a long complex job stop in the middle. Home point lost.

When I do use Easel as a sender now, I get my X/Y zeroed and plunge down with the spindle running to mark a positive stop home point. Then I set my Z home. Then at least if the job fails half-way through. It’s salvagable by resetting home. But I don’t rely on it for anything I’m going to cry about if it borks up.

It’s the only USB connection I’ve had that’s “disconnected” by itself. Printing, long audio recording sessions, video transfers, external USB drives, MIDI devices…never a fail since the advent of USB. I wouldn’t be blaming the USB here.

This was happening to me almost every carve. I think in my case it was electrical interference from my Makita router. Since I turned the speed on the router to as slow as it will go, no more premature finish.

Argh. Garbage. Inventables, can you track down and fix this please? This just wrecked my son’s job an hour in. He still uses Easel. I’ve wholly given up on it as a sender.

1 Like

I ran across this a few times in the beginning.

About the third time it happened, I tore apart the X Controller looking for the issue.
What I found was that some of the ribbon cables were latched, but not fully seated, causing a multitude of erroneous errors, with the usb disconnect being amongst them. (lost steps, occasional side steps, etc being others)

Once I made sure that everything was fully seated, I hadn’t run across the issue again until I recently installed a Laser from OptLasers on to the x carve.

Running the laser on PWM output, and the Spindle (Dewalt DW611) through an IOT Relay with a shop vac, I would get an EMF bounceback through the controller that would knock out my USB connection. To resolve it, and prevent the IOT Relay from fluttering during a laser operation, I now simply disconnect the spindle’s IOT Relay when using the laser.

I have not had a single disconnect since then.

Oh, I did recently have a 24v power supply issue inside the X Controller. One day it just decided not to show up for work. I called Customer support, and they actually warrantied the Power Supply for me, and immediately sent me a new one. I couldn’t ask for better service, ever. I was completely willing to pay for a new one, but they wouldn’t take my money.

That was prior to installing the laser, but after I resolved the loose ribbon cable problem, so I’m not sure if any of that was related.


I’m a noob at this so reading the threads has been a big help, but… today when I was trying my first real carve it stopped about half way through and just sat in position and asked how did it look. Spindle was still lowered, it just stopped. Turned every thing off, then back on, then proceeded to recarve. Machine found a new home and ripped a new line through my project. Not a serious piece of material (trying Azek) and it worked well til it stopped. Any thoughts?

My 10 year old still uses Easel for my machine. What I have him do at the start of every job before zeroing the Z axis is:

  1. Find your XY home
  2. Turn on the spindle and manually lower into the workpiece to mark a start index.
  3. Raise and shut the spindle off
  4. Then do your Z probing or manual zero of Z axis
  5. Carve.

This way, if a job quits in the middle, you at least can find your exact work coordinate home, re-zero and start again.

And if you have big jobs, break up into smaller processes. Then if one quits, you can start from the beginning of that process instead of the job start. It’s a bummer when you are three hours in and have to restart.

Or switch to another G-Code sender. In my experience, this only happens with Easel. I can’t make sense of it. The other day he ran a 6 hour job straight with five different carve strategies and it ran fine. Other times it’s quit in a five minute carve.

Electrical noise, tripping the USB connection most likely which causes a very brief disconnect and Easel think it has stopped.

Try a externally powered USB hub (=stronger signal link, better at attenuate noise)
Use the lowest RPM setting of your Dewalt (The earlier QT spindle is very EM-noisy in comparison)
Make sure the USB port isnt affected by your PC PowerManagement etc.

I summarized my experience with stopping carves here

Maybe some points are valid for you.