Jtech 2.8W Laser lines are not dark enough

Okay, I have my laser working top notch, Universal Gcode Sender makes a perfect design… except its to light. How do I control power? I have changed my feed speed on the “laser cutting bit” on vectric and lowered my laser on the z axis. I have power set to 200, I think?!, I have searched the forums and changed settings a bit , but all the examples seem close to the same. What am I missing??!

Max power should be 255, and can always go slower


I think I have figured out the issue, by changing the depth on the tool path it passes over more than once, but on long runs it is still very faint or none existent, small designs like a box seems fine, but long runs the laser goes by too fast, any tips on feed rate? I have it down to 5 in/min. I will keep playing with settings but any ideas are appreciated Thanks

I must be missing something, I have it set to 1 in/min and it is still moving too fast. I must need to adjust something somewhere else

I get some pretty dark lines with max power and even 45 in/min but I have the 3.8watt, I can’t imagine the 2.8 is that much different but I’ll let somebody with a 2.8 reply…

What version of grbl are you running?

Which post processor are you using with your Vectric product?

Did you focus the laser?

that would depend on the GRBL setting for $30=(speed) his could be at the default of $30=1000. which setting m3 s255 would just result in about 1/4 power. but if his $30=1 the it would full power at anything above m3 s1
hope this makes sense and helps

I have set
$30 = 255
$31 = 0
#32 = 1

I think I solved a bit of my issue. I slowed x and y acceleration down to 250 last night and it worked much better. I think I will go down to 150 tonight and see how much better it looks

1 Like

I have tried a few, 0.9 was giving me the same issues so I installed Jtechs grbl and my x and y axis were backwards. So now I am running grbl_1_1f.20170214.hex which runs the same as 0.9 so far. not including some of my fixes

I installed Jtechs PP inches with no Z(the other x carve version is a dead link)

If you don’t need spindle speed or feed rate over rides, this version of grbl might be a better choice for you.

It should work better than 1.1f with Vectric products.

For reference here are the settings I use to test the laser code:

$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=18 (status report mask:00010010)
$11=0.005 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=1 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=255. (rpm max)
$31=0. (rpm min)
$32=1 (laser mode, bool)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=7650.000 (x max rate, mm/min)
$111=7650.000 (y max rate, mm/min)
$112=2540.000 (z max rate, mm/min)
$120=8000.000 (x accel, mm/sec^2)
$121=8000.000 (y accel, mm/sec^2)
$122=150.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=90.000 (z max travel, mm)

it is an x-carve and I did set it to 8000 and it just about broke it. it moved so fast that when it stopped it hammered and when I shut it down and it returned to my start it was off by about 4". I thought about it today and am wondering if my numbers are imperial?

no its set to 255 now, and as far as I understand my grbl is set to max 255 ($30 = 255)

I will not deny that, Inventables made it too easy, I have never needed to tweak any of these settings for carving wood. I have found that $13 controls this and will check it when I get home tonight. Thanks for all the help so far!

Yes. In the above picture the tool speed is 200.rpm. Depending on the setting of $30 (max rpm) and the version of grbl you are running any setting for rpm >= the value in $30 will give you full power.

Since his tool setting is 200 and his $30=255 the power level is 200/255 = 78.4 percent.

1 Like