[New Feature] Carving Time Estimation

You can now get an estimate of the carving time inside Easel while you are designing! I wanted to show off how it works and hopefully get some feedback.

The “Show Toolpaths” button is replaced by a “Simulate” button that, when clicked, will calculate and show the estimated time and toolpath visualization.

CAM programs are notoriously bad at giving machining time estimates. It is a tricky problem because of all the different possible machine setups. But we really wanted to give you a tool that you could use to get a rough idea of how much time a design would take and to see how changing the bit size or material thickness impacts the carving time.

We’ve been experimenting with a couple of different methods for estimating time and comparing these estimates with the actual amount of time your carve takes. Here is some data from the last few days:

You can see that we almost always are underestimating (something to keep in mind when using it) but for 95% of people the estimate is correct to within a few minutes.

There are a couple of improvements I know we can make to this estimate to tighten up this range, but I think this is a very good start.

Big ups to @EricDobroveanu, @Ruwan and @rodovich who worked on this feature with me.

We’re very interested in hearing what you think!


YAY! Great job guys! Looks good!

1 Like

This feature also works very well with the two stage carve feature. Carving this snail with a 1/16" bit takes a long time, but using a 1/4" bit to remove the interior and then using a 1/16" bit on the rest makes it take way less time.

Only 1/16" bit (about 29min):

Compare with 1/4" + 1/16" bits (6min roughing + 8min detail):


This is awesome! Thanks for adding this in!

1 Like

I got time to run a carve on mine today and it did the same thing. The carve went great but I couldn’t pause it or stop if needed. Had to quit the browser and start another just like you Phil. I’m running it on a netbook running win xp and a slower processor so that’s what I though was the issue. Oh and running Easel with Firefox since chrome crashes all the time on that machine.

1 Like

@PhilJohnson what OS and browser is that?

I’ve been having the same issue lately as Phil using Vista and Firefox. Usually Chrome works fine. It’s typically not a big deal, but it makes me nervous not being able to pause the build were something to go wrong. However, it seems to be quite random. When it does occur, I typically have to restart my computer, simply closing and re-opening a new browser doesn’t work.

@PhilJohnson @Scotts Have you guys been able to decipher a pattern? I haven’t been able to replicate the issue. Do you have a project that it seems to happen every time (or often)?

1 Like

I didn’t run the machine for a few weeks then tried this past weekend after the pen and simulate functions were added and that’s when the issue came up. The netbook I use doesn’t touch the internet except for easel and I don’t run the daily Windowz updates nor the java and anything else I wants to do. I have not run this on my Mac yet as I have desktops. Not sure if it matters, but the preview doesn’t show on my netbook with FireFox but it shows under Chrome but then crashes. I do 99% of the work on the Mac then open the file on the netbook for carving.

Here is the link to the carve. I have not tried other carves, just adjusting the numbers on this one for a project.

1 Like

I had the same problem last week using Chrome on Windows 7 in a Virtualbox VM. If you just refresh the page, it comes back. I didn’t get any glitches in the carve by reloading. It just clears the popover and you get the pause/stop controls again.
It’s annoying but doesn’t seem to break anything.

Hey @PhilJohnson sorry about the issue. We have found the problem and will deploying a fix shortly.

1 Like

@PhilJohnson The fix has been deployed, so you should be all set now.

1 Like



On XP? That’s amazing

1 Like

Can you take a screen shot and post it back?

AWESOME. Such a great improvement.

I was carving on the weekend again and Easel is working properly again. Thanks to the Inventables team for fixing it so quickly.

Now we just need to get our roughing pass to leave a little on the Z axis!

1 Like

I think it is a great feature and so far I’ve used it for 4 jobs and for me it has been fairly accurate Thanks again

There must be something wrong with mine, i am 17 minutes into a “About 5min” cut and i am only 36% done.

Edit: Final time for the cut 46min