New to x-carve, need help with easel

New to x-carve and trying to figure out what I am doing wrong. I am trying to the 50 stars for the union, on easel I have on the x-axis 15 inches and on the y-axis 10.5 inches, once I go through the steps when I hit carve it goes to about the 7-inch mark instead of 10 inches and it doesn’t plunge down to where I want it and creates small stars. Can someone please help me out?

Are you setting the home position to the lower left corner of the piece of wood?
How are you setting your Z axis?

The metal piece that your clamps are resting on should be standing up and the flat side on the bottom, then the notched will line up perfect.

Yes, I set my home position to the lower corner. I set my z-axis to 0.75.

Thank you for that, I’ll fix the clamps.

Assuming your setting everything up per the instructions, Then your grbl settings may have changed, im not sure if this is due to the recent addition to the new machine settings roll out in Tuesday, but there seems to be a larger number of ppl reporting this issue this week :man_shrugging:

You can go to machine>general settings>machine inspector to verify and change your grbl settings.

Here are the default settings to verify yours to.


That’s what I was thinking as well, the router was going up instead of down and down instead of up but I did manage to fix that. Thanks for the link. I’ll look into it.

Definitely have different numbers than the default ones!

Welp, just changed the settings, now x,y, and z-axis does not work.

Did you have the bit on the edge of the piece of wood when you set the home position? It starting cutting the first star and the X axis looks good but the Y axis was cutting to low.
What settings did you change?


yes, I had it at the very edge. The y axis kept coming short and the stars were smaller and not deep enough.

There were a few settings I changed in the Machine inspector. I believe it was 20, 22, 100,101,102,112,130,131

What were the 100, 101, and 102 set at?
Do you have the upgraded XCarve?

20 and 22 have to do with homing, so if you had previously had them set to 0, then homing (22) and the machine limiting itself from driving outside of the work area (20) were turned off. and as a result your machine will now not allow you to move it without clearing the error state be homing the machine.

The 100,101,102 were the calibration of movement and if these were previously not set correctly, theses would explain the issue with sizing…

You can turn 20 and 22 back to 0’s if you prefer to not use the homing feature, totally your preferences for this part…

no, I just have the regular one 1000/1000. And I cant remember what they were before.

Ok, I turned 20 and 22 back to zero (x,y, and z works now), any idea what 100, 101, 102 should be? I don’t have the upgrade just a regular stock 1000/1000?

The values on that page are for the regular 1000x1000


Sweet, I set it up to 40, 40, and 188.974. It went up to where i wanted it, now its starting to shift to the left

I ran it through the entire carve just to see where it’s at and this is where I’m at now. Still coming out short on the x-axis and some stars looking weird.

1 Like

Um, I made this video before noticing your X belt issue… this is not how this belt is supposed to be ran…

It should be routed Under the black plastic pulley and yours appears to be routed over it… or some other way I have never seen b4… Here’s some good photos to show the proper placement…

Here’s My take on your Carve and what might have caused part of it… that Said, I recorded this Prior to noticing the belt routing issue…

Here is my video on Shimming to get the top parallel, which I sometimes HAVE to do for unions when Surfacing on the CNC is not an option… I’ve only had to do this about 10 times and it resulted in perfectly crisp star points…

1 Like

holy crap :exploding_head: I definitely missed that! Yea I just have it on the pulley instead of under, up and over and under. It might have been when I was fixing it a few times and missed it. Thank you for that!

I used the 90 degree 1/8 shk bit. The first star on the top left I ran it twice so that’s why it looks like that, I didn’t do roughing and I set my XY at the corner and not where the star was. Thank you so much for helping me. I will look into the link!

1 Like

with the right grbl settings now and the belt routing fixed, you should be good to go, just might want to surface the workpiece or shim to get the top perfectly parallel to gantry :+1:

i just realized I left out one other video about more precise calibration… you can do some movements like in this video to verify how close to perfect the default settings are for you, but small imprecisions in the pulley size or belt tooth spacing can result in slight variation to the default settings, and this is how to get it perrrrrfect.


I fixed the belt routing and it came out so much better! Once again, thank you for all your help!