Inventables Community Forum

[NOW LIVE] [new feature] G-code sending through easel

I think it would save time at this point to list the people who don’t want to test this feature.

This would be excellent.
I would love to try this.
I’ve tried using u.g.s. with no luck

Would like to try this feature

I use fusion 360, can I have access to g-code import please?

Yes, please!!!

I’d like to try this feature as well.

I tried tapping my heels together three times, and thinking to myself “There’s no place like Inventables … there’s no place like Inventables”, but it didn’t work. :wink:

Perhaps one of the great and powerful wizards can help me out?

1 Like

I would love to try this out

Side note. You allowed me to try 2 stage cutting and just wanted to say A++++ good work boys keep the features coming.

Could you please add me to the list, I am using Aspire and need a better way to send G-Code.

Hi, the Gcode feature is great. Love it! Great job. Just wondering if there is a Vectric mm post processor. Maybe I missed it, but I got it generating inch output.

Got it solved. Here is the adapted file. Replaced the G20 by G21 and corrected naming to show correctly in Vectric. vectric_easel_mm.pp (3.0 KB)

Could I please be added as well?

Hey everyone from the weekend who posted has been added. Here is a quick update on where we are with this feature.

We are adding the ability for Easel to save the imported g-code on your project so that it actually becomes a real project that you can name and keep for later. We are trying to release that within the next few days, and will gather feedback about how it works.

There are also two more features that are in the pipeline that should land in the next week or two:

  1. Import as much information as possible about the stock and bit size so that we can present that information during the carving walkthrough.
  2. If information isn’t available, remove the corresponding steps from the walkthrough so that it isn’t confusing or misleading.

Also small note for Carvey users: using F360 there is an automatic 1" offset applied to your design to avoid the Smart Clamp. X-Carve customers have already noticed this, but you can disable it if you want.

For anyone new to this feature, make sure to read the thread history before asking new questions, most things have been answered already above.

Thanks again so much to everyone trying this feature and giving feedback.

2 Likes

Please add me to the access, Thanks

Hi,
Can i please also have access to G-code sending. I’m just about to start learning Fusion 360 and i’d like to keep using Easel to send the G-code as i know it will work with my X-carve.

Thanks

Paul, this is exactly what I have been needing, can I get in on this please and thank you.

Hi @JohnHarvill, @Alex1380, @JohnCompton: you guys have access!

I would like to have acces to this feature as well.

I had already created the end mills and the toolholder in fusion360 I will put it in a separate topic because this one is close to unreadable with all the me too’s in between

About the toolchanges …
What I do right now with ugcodesender 1.09 is edit the gcode and replace every T? M6 with some code moving to upper position and the x and y zero point of the current part and the a M0 to pause. To continue cutting I pasue and then resume in ugcodesender.
Works a treat.
This could be extended with a toollenght offset but i did not go into that yet.

I have been playing around with this feature and have been unable to get it to work. I am using Fusion 360. The exported gcode always contains an extra deep tool movement that is not visible in Fusion 360.

Below is a circle path made with fusion360:

And here is what it looks like in the easel software:

Notice the single, deep y-axis movement that goes from the edge of the circle down to the bottom of the grid between the 100 and 110 mm marks.

That extra movement shows up in ChilliPeppr as well, so I assume the problem is in the Fusion 360 settings or with the export process, but I have not been able to figure out how to make it go away.

Any help would be appreciated.

Update - I have found a work around. The problem is associated with the addition of tabs. Removing all tabs makes the problem go away. If I want tabs I have to tweak their size and spacing until I get an exported file with no extra cuts.

1 Like

This would be great and get people to carving much faster. I really like the X-carve, but this will improve the whole process…thanks.

@WouterPortegijs, @AllenKerr—you now have access to the g-code sending feature.