Object Size & Accuracy - From AutoCad to Easel Pro

I’ve discovered when I create a design in AutoCad and transfer the DXF file to Easel Pro, the image is very small in Easel Pro and not the actual size I intended. Of course the item can be enlarged in Easel Pro, but that’s not helpful when designing precision parts that must fit together.

AutoCad drawings are created in actual size. When I have several drawings of parts that must fit together with a certain degree of precision, I can easily achieve that in the CAD environment. Transferring images from separate drawings to Easel leaves me without any means of making them all the same sizes as intended in CAD (at least to the limits of my knowledge about Easel Pro).

Is there a way to do this in Easel Pro?

I have the same issues going from fusion360 to illustrator to easel.

  1. Draw a reference rectangle of known dimension around your drawing. Resize that rectangle, with the rest of the drawing, in Easel to scale things back to correct.
  2. Try the new DXF import App, under “Apps”, at the bottom.

Thanks, NeilFerreri1.

I have indeed been using the DXF import app (under apps at the bottom). I’ll give your rectangle solution a try. It should be sufficient for many wood working components where accuracy with close tolerances are not so much of a consideration, but I would still be suspect of the accuracy level one might achieve on a consistent basis.

Most of the DXF files I would import are actually quite small (in two digit kilobytes).

I’m using a very old version of AutoCad (Acad2002) to generate my drawings and save in DXF format.

Can you share an example DXF here?
EDIT: Saw your post on the other thread. I’ll default to the more capable @JelleVanRegen.

Sure Neil. Here is an example of files I’ve had issues with:
sign shape 1.dxf (18.5 KB)

I can’t get anything to work with the app right now. I’m not sure if it’s my browser or what.

Sometimes I can’t get anything to work either, but I can’t blame the app. I live in a very rural part of Maine, along the seacoast, and the local phone company won’t invest in their DSL infrastructure - we’re always having internet connectivity & speed issues.

I get this error:

Anyway, I’ve used the rectangle for scale method with some things that needed to be pretty precise. I’d think the only limitation would be the precision of Easel and how it handles rounding.

Hi @NeilFerreri1, @PaulJ.Bennett

I don’t know what caused the error but it wasn’t me, I was quite asleep when you had the error. Everything worked when I went to bed, and everything works now. I did do some minor changes about 24 hours ago but nothing that would cause this.

Here’s a print from my easel app with your DXF :

If you want, I can try some other DXF’s you had problems with.


1 Like

@JelleVanRegen It must’ve been on the server side. Same files are importing now, with no changes. Maybe it only works when you’re awake? :wink:
I’m still not seeing the correct scaling, though.

Dear god lets not hope so :smile:

I was messing around today alot with new versions trying to get every dxf I have in my library to work so that’s why the scaling stoped working. It should be better now. If it isnt, I continue to work on it tomorrow.

I have a 30 ish dxf’s to test from, I have 2 that still dont pass so Im close to a stable release :slight_smile:

Thanks for the input @NeilFerreri1