Oh no, not again...!

In my last epic thread my machine was cutting the job in the wrong location on the material. After replacing the Arduino and running some test cuts, all was perfect. I come in today to run my first real job and things are back to their old ways. I try to run a job but it cuts in the wrong location. I even tried cutting a simple circle in the middle of the material (12"x"12 piece of acrylic) but it tries to cut it about 1" up from the bottom edge. I’ve restarted the computer and homed/zeroed the machine many times.

The one thing different this time around is that I was able to connect to UGS and run a $$ command. Here are the results:


Side question: Any idea why I can’t copy and paste the $$ results from UGS…? I had to take screen shots instead. When I try the standard command-c, command-v it would not work.

@TaitLeswing…Please let this time around be a simple fix…!!

@WilliamPaukert can you type $# in UGS and post the results?

I just went through this last night. I was swapping firmwares and when i went back to grbl 0.9 it had the correct settings but it didn’t honor them (like axis inversion etc).

The fix is simple, run Examples->EEPROM->Clear from the arduino IDE, then reflash with the inventables version of grbl. then rerun the setup software and it should be able to set the values correctly.

Here’s the inventable firmware
https://github.com/inventables/grbl3

I’m running a 500mm with acme and nema23 incase it matters.
Here are the default values of the inventables version
Grbl 0.9i [’$’ for help]
[’$H’|’$X’ to unlock]
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=250.000 (x, step/mm)
$101=250.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

@TaitLeswing…Hello again Tate. Here are the results of the $# command:

@WilliamPaukert Are you trying to cut from Easel?

@TaitLeswing…Yes, I am cutting directly from Easel. One job was an imported SVG and the other was just a simple circle I tried to cut. The simple circle was drawn in Easel as a new project

@WilliamPaukert When you’re going through the walkthrough after you click carve are you asking it to “use the last home position”?

@TaitLeswing No, I am resetting the home position every time.

@WilliamPaukert forgive me for asking the obvious, but are you resetting the home when the bit is at the bottom left corner of your material?

@TaitLeswing…Yes.

@WilliamPaukert can you close Easel, open UGS, jog to the bottom left corner of the material (where you want your zero to be) and type in G10 L20 P1 X0 Y0 Z0 please?

@TaitLeswing…OK…Did that.

@WilliamPaukert Ok, now type G54

and then $# again

@TaitLeswing…Just did the above with these results:

@WilliamPaukert Ok, now close UGS, open Easel, load your design and click carve, follow the walkthrough and re-specify your home in Easel please

@TaitLeswing…Just tried the above, running a new project in easel… Again, a simple circle. Re-homed the machine in Easel to the bottom left corner of my material. But no go. Tried to carve in the wrong location. You can see in the pic where it is trying to carve. It should be carving dead center (6, 6) on a 12"x12" piece of acrylic. you can also see that after canceling the job the machine did not return to the proper home position either. It should be at the exact bottom left of the acrylic.

@WilliamPaukert Can you link your Easel project please?

@TaitLeswing…>Sure thing:

http://easel.inventables.com/projects/sDxpIrOu2sIR2ynmupJMbg#

@WilliamPaukert thanks, can you close Easel, open UGS and type G92.1 please, then reopen easel and try to carve the project again please?