Oh no, not again...!

@TaitLeswing…Just tried that and got a similar but slightly different result. t I starting cutting in the wrong place again, but this time the location was about .5" closer to the edge than the previous wrong cut.

Also, when I open UGS, I am getting this:

Hitting the $H will clear it so that it looks like this:

@WilliamPaukert Can you do the following:

  1. Export the g code from easel (it’s under machine, advanced)

  2. Close Easel

  3. Open UGS

  4. Jog to your home position

  5. Type G10 L20 P1 X0 Y0 Z0

  6. Type G54

  7. Type G0 Z0.15

  8. Turn on your spindle

  9. Load the gcode from Easel and send it

@WilliamPaukert is the circle the right size? It looks smaller than it’s supposed to be…

@TaitLeswing…I’ll try the above tomorrow when I get back to the shop. Regarding the circle size, it might be the right size–but I usually stop the machine as soon as I see it is about to carve in the wrong location. I’ll check for that tomorrow as well.

1 Like

Here is my opinion (and Im no expert just a noob!) if the circle is not the right size you may have the design set in inches and the machine set in mm. If the circle is the correct size then when the spindle moves quickly to the start point of the project you may be loosing steps some how, especially since the spindle doesn’t go back to the correct position when stopped. I would first check all the belts tension. If the belts are good then you may not be getting enough current to your motors and the Pots may need to be adjusted very slightly. I was loosing steps in my Y axis and found out I needed to raise the Pot on mine and has been running fine since. I would definitely let an expert confirm my suggestions, I just thought I would mention those things to check!

@TaitLeswing…Here is todays update:

First, everything was shut down over night and rebooted this morning. I tried what Tait describes above. Do everything to the letter. All commands execute and the project loads perfectly. But when I send the job it once again it cuts the shape in the wrong location. The location is pretty much in the same wrong spot as Easel was cutting before.

So then I start yet another new test project. This time its some 1/8" MDF. I start a new project in easel. I tell it to cut a 2" circle dead center on a pice of material that is 6.5" high by 17" wide. I hit the carve button and it runs perfectly. Correct shape size, proportions and location. See image below:

Next I close everything down again, open up Easel and load the acrylic circle test Easel project that I sent to Tait. It should be a .5" circle cut dead center on a piece of 12"x12" acrylic. But once again it cuts it in the same wrong location as before. See image below:

Huh…What does this mean…?? Now I’m kinda scared because of the unpredictability… :fearful:

Can you share those two Easel projects and post the links?

Sure thing @PeterJames …!!

Here is the one that cuts wrong that I sent to Tait:



Heres the one that cut correctly:


Looks like you need to share those publicly, don’t know if it will generate different links or not.

@PeterJames…Just changed the share settings. Here are new links just in case:



Just for reference, here is a quick video of a new project test. This one did not work… Correct shapes, correct size, correct orientation, wrong location. Compare to the image of the Easel project.

IMG_3943.MOV (4.8 MB)

Sorry for jumping into your discussion, this is very similar what I had once.
Are you certainly sure you’re uploading correct hex file to Arduino after erasing eeprom;
This one I used and get rid of coordination mistakes. grbl0_9i_X_Carve_500mm_ACME (1).hex (80.3 KB)
500mm doesn’t means anything. After upload successful, I started Easel and setup my machine with correct parameters.
just a thought.

I had an issue with my first Arduino. Inventables sent me a new one. @TaitLeswing flashed it with the latest grbl before sending it to me. I haven’t opened, uploaded or modified the Arduino in any way since receiving it.

1 Like

@TaitLeswing, @Zach_Kaplan…There’s been almost another week of downtime since this latest problem started and still has no resolve. I know you guys have a lot going on, but I’d really like to try to get to a solution and start using my machine. It’s been down and unuseable for three weeks now. I’ve tried a few things above since last hearing from Tait with varying results. So far I’ve only tried the suggestions from the Inventables team. Do you think I should go after some of the suggestions above from others…? They include:

1.Adjusting the current pots on the G shield.
2.Re-uploading the grbl Hex file. This one seems odd since Tait flashed my Arduino prior to sending it to me, but I’ll try it if the Inventables team recommends it.
3.Running the EEPROM clear on the Arduino, again seems odd given the above, but willing to try anything at this point.

–Should I look at getting a different computer in for running some tests…?
–Can you give me an indication of where he problem is likely to be–my computer/software, hardware/x-carve, Easel, etc…

Also, if there is someone else on the team that I should be contacting, or a different means of working out the issue, please let me know and I’d be happy to follow up that way.


@WilliamPaukert sorry for the delay, let’s get this fixed for you.

Let’s start from the top again and make sure it’s not a mechanical issue.

Can you:

  1. Check that the set screws on your x and y axis pulleys are as tight as you can get them without stripping

  2. Make sure your x and y belts are taught but not overly so

  3. Slowly and gently move the machine along the y axis and x axis and check that it moves easily (if it doesn’t loosen the eccentric nuts evenly until it does)

If you have uploaded Grbl’s newest firmware as of this weekend, I installed a EEPROM restore feature. You can wipe the work coordinate offsets with one command $RST=#. This will zero all of these parameter in EEPROM. Much quicker than using lots of G10 commands.

FYI, there are other $RST commands but it’s important to make sure your Grbl build has the right defaults that it was built with. For example, in config.h, you;d need to change line 34 from #define DEFAULTS_GENERIC to ``#define DEFAULTS_X_CARVE_500MM` for an X-carve 500mm so that when you restore the settings they are the right ones.

This only applies to Grbl after 2015-06-20. Prior builds do not have these restore commands.

@TaitLeswing…Thanks for the response. I just found out I need to travel for the next few days, so I probably won’t be able to check the above until next week. I’ll respond to this thread once I do. Regarding what @SungeunJeon mentions above. Is this something to consider…?

@WilliamPaukert Ok, please keep us posted and again I’m sorry for the delay.

@SungeunJeon is the lead developer of grbl so he knows what he’s talking about :wink:

However, you have an earlier version of grbl that doesn’t have the features he’s talking about so don’t worry about them yet.

Soooooo. Here is the latest on this. I believe the problem has been fixed. All along the issue was presenting itself like a software issue, but it appears to have been mechanical. I took a half day and did the following:

1.Tuned all of the v wheels and eccentric nuts.
2.I completely loosened and re-tensioned all the belts.
3.I adjusted all of the voltage pots by marking the current “factory” position and then the highest and lowest settings. They were set under half-way, so i bumped them up to the half-way mark.

I’ve run three different jobs and things are now cutting correctly. The very bizarre thing still, is the random job that worked correctly (earlier in this thread) when I was having the issue. The only thing I can think of is that this job had a shorter initial rapid than the other jobs, so it cut the circle in the correct location. It’s still weird to me that the shapes that did get cut were the right size and shape. I guess this points to the motor voltage effecting the rapid movements, thus cutting the right shape in the wrong place…? Thanks again to @TaitLeswing and all for their suggestions and support.

Yes, it seems that running the motors at less current than optimal would make just the rapids off.