Inventables Community Forum

Problem on carving round circle

HI all! i have finally received my x-carve, i assemble it then i start to setup and make some test.
Im very disappointed because i need it for very precise works, and i see that:
its impossible obtain a perfect round circle :frowning: how is that possilbe?
how can i solve? i need to make very precise cut instead in this way all circle are oval. For example i make 80mm x 80mm and the result is 80mmx80,5mm

It cuts perfectly and precisely. Only way to solve it is that Magnifying glass on top right. Just put anything you want to know, you’ll be amazed how much information about tuning your system after build. It’s way too early to give up. It took all of us to go steps to make one solid carving machine.

4 Likes

im also check the gshield try to make sam manual adjustment to the power of x and y aces but i not get any result improvement, im readin other post you have any suggestion for me?

now i put $101=39.750 and seems better and more round now the difference is about 0,20mm tomorrow i make more try

1 Like

Also, once you are sure your machine is assembled correctly, and square. Calibrate your stepper motors using information found in this thread:

I have found something interesting when I was carving today. I have had some issues with perfect circles as well. My machine is dialed in and is very accurate on everything (steps per mm are dead on), even arcs and curves–but the perfect circle is like the holy grail…

Then I tried cutting a circle drawn in Inkscape with Estlcam and UGS. Perfection! This makes me question Easel and how toolpaths are calculated for circles. I flashed my Adruino back to the X-Carve GRBL and tried the same cut in Easel. The circle was perfect along the Y axis, but had a very slight flat spot at each of the X axis extremes–we’re talking only 1 or 2 tenths of a mm–but it is noticeable. I’m not losing steps… They just don’t happen, like they aren’t in the code. The size of the circle doesn’t matter either. I haven’t tried generating the gcode in Easel and using UGS to carve, but that should produce an imperfect circle as well if the problem is Easel.

I cut an S pattern to check for backlash in the X axis and the results were perfect in Easel. I cut a C pattern and it was right. Even a capital O works fine. But the circle shape produced is consitently the same (imperfect) shape from 1/8" all the way to a 6" diameter test that I tried. It just looks like the same wrong shape scaled up or down.

1 Like

please can you explain me how can i cut a circle using your same software? i only know Easel.
I want try your suggest

im download eastcalm now i try to understand what is UGS and how comunicate with x-carve

UGS is Universal G-Code Sender. Download it here:

http://bit.ly/1hftIhy

This software is used for sending the G-Code that is generated in your CAM software to the Arduino.

Just be aware that setting up Estlcam to work with the X-Carve will prevent you from using Easel, unless you reflash the GRBL. Estlcam flashes its own firmware to the Arduino. You are getting into the realm of moderately difficult tasks if you are unfamiliar with all the nuances of machine control. We are here to help.

But, before spending time on experimenting… make sure that absolutely everything else about your machine setup is correct. Your circle issue may not be the same as mine. Others have no difficulty at all with perfect circles and Easel–so I don’t know what is different about my experience. I will be doing some additional testing today to see if I can transfer the problem by exporting Easel G-Code. If that is the case, then I think I have proof that in my case there is a software glitch somewhere in the workflow with Easel. It may be the way that the circle is vectorized in another piece of software before it is imported… but I hope to have more evidence to present shortly.

OK. I have found the cause of my circle issue.

I have a stepper motor that is not responding properly. My X axis stepper motor in not moving a full distance per step, but only on a direction change. So if I have it jog 1mm, it is only moving 0.5mm on the first step and then 1mm each step afterwards. Then when the direction changes the same is true. However, if the motor is being held in place by current this doesn’t happen. I swapped the X and Z axis motors and the problem is gone on the X axis. The issue isn’t as important on the Z, and the incorrect movement is smaller due to the screw. I will see about getting a new one from Inventables. This is not a slipping shaft issue. I marked the pulley and shaft and they remain in the same place during operation.

The reason it didn’t happen with Estlcam, is because the way the GCode for a circle is calculated in that software. It doesn’t make a smooth arc–it makes lots of little tiny straight lines that overlap to create the circle shape. So, the error in the X axis motor was really tiny and not perceivable, even though it must be in there.

@LorenzoGuarnieri, I’m not sure if this is the cause of your circle problems, but this is what I’ve found in my case.

1 Like

It behaves exactly like backlash, but I swapped motors and the problem moved to the new location.

About to give up any hope of having a round circle. I’ve had the machine since July and have been working on this sine then. I’ve made some really nice projects but have yet to get a round circle.


The brushes pictured in the pictured are for another post.

As you can see, the sides (X direction) are elongated. I can’t get this out of the geometry. I’ve adjusted belts by “twang” and also by fish scale; I’ve adjusted pots by observation and vref; I’ve upgraded to the Xcontroller; I’ve gone faster and slower for feed rates; higher and lower for DOC; Loctite on anything that can turn; stiffening mods on both axis; the problem remains. One thing I did observe, in the following video, I can see the vwheels stalling at both X limits of the shape. Unlike the Y limits (or anywhere else) where the wheels continually move. Being a circle I would think X and Y would be continually moving.

Absent anyone seeing the issue or having any advice in addition to whats previously been posted I’m crying Uncle on this aspect of the machine.

EDIT: The pictures are turned. The X runs up and down in the pictures, the Y runs right to left.

Um. Is your Z axis delrin nut worn in? This can cause incurable slop when changing directions and, including myself, I’ve seen several people in the forums receive warped ACME rods which cause wear in the threads of the delrin nut, eventually leading to increased slop in the rod/nut fit and poor stiffness. You can check for this by running your Z axis up and down and watching the rod for any bowing while it’s moving. Alternatively, if you really love taking your precious machine apart and burning up time, you can remove the Z axis rod and roll it on a flat, well lit table and watch for warping there.

EDIT: Oh, there’s also data rates. It occurred to me after reading @ChrisSlaten’s comment above. If your tolerance while processing the CAM is very low (I don’t know what the “tolerance” variable is called in CAM processing software other than Fusion360), then you can run into a scenario where the controller (being a relatively crappy 8MHz arduino…) can’t read the next XY location that it should be going to faster than it gets there physically! Talk about a head trip. Test whether this is the case by grabbing some MDF and milling a square, then a hexagon, then an octagon, then a dodecagon, and continue working your way closer and closer to a circle. I actually think the significance of data starving is enough that curve fit tolerancing max values should be a more common discussion topic in the forums, and a more common suggestion for standard new owner reading material.

1 Like

In my mental vacations while at work today I came to the realization that the computer is the one last remaining variable. It is the only thing I haven’t tweeked beyond belief trying to cure this problem. Your input makes me think that this might not be an issue as the arduino may not be able to handle the flow coming in but this is to the point of being a quest.

I don’t rule out the Delrin but since this has happened from day one I’m going to try switching the computer and usb cable. If no happy is obtained I’ll tear it apart…again…to check the acme and nut. I love this machine (seriously) but this one thing is wrapping me around the axle.

Thanks for the input. I’ll post back with results.

I would love to hear a solid fix on this issue. I’ve had the same run around as many poeple. I use Easel only and while maintaining my machine, v-wheels, belts, yadda yadda yadda, I have improved the circle and then adjusting the potetiometer helped a bit and then finding that straight flutes work better than spiral bits, I still cannot get a perfect circle. And what is so weird is that I can cut a large circle with very minor, almost incalculable, error but I can’t cut a good hole barely larger than the bit.

I’m curious about the delrin nut and bolt, but I’m more suspicious of the flex of the v-wheels on the z axis. With my hand I can move it a bit side to side so this can’t be helpful.

I think it’d be worth attempting the same job with another G Code generator. Just to see if you get the same results.

Maybe, though I’ve read people having trouble with Easel cutting circles and others having alternate programs give them issues and only Easel producing a perfect circle, so I don’t know.

I struggled with this problem also. I tried everything I could think of but nothing improved, Finally I loosened all the v-wheels somewhat ( they were tightened correctly to start per the instructional video ) and Bamm!! all of a sudden it was cutting near perfect circles. My wheels are a lot looser?? than I thought was correct but it works great now so I’m happy.
May be something to try.

2 Likes

Have you continued with the loose v-wheels? Has the problem come back? I have about to pull my hair out. Belts, potentiometers, ACME rods, everything squared, yada, yada, yada. I have had problems with one particular v-wheel being loose. I did try to tighten it recently and then my circle problem came back. Curious if this was the definitive solution for you? Did it cause any problems with other cuts with the loosened v-wheel?